summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-18 03:49:49 +0100
committerSam James <sam@gentoo.org>2024-09-18 03:55:28 +0100
commitcecf4748804bd1a878c94eb448540c29f2418c1a (patch)
treedd9fb8a70ae8a09d14b16f168508eae27e7e8be1 /dev-lang/rust-bin
parentsys-fs/cryptsetup: Stabilize 2.7.5 ppc64, #939797 (diff)
downloadgentoo-cecf4748804bd1a878c94eb448540c29f2418c1a.tar.gz
gentoo-cecf4748804bd1a878c94eb448540c29f2418c1a.tar.bz2
gentoo-cecf4748804bd1a878c94eb448540c29f2418c1a.zip
dev-lang/rust-bin: drop USE=profiler in 1.81.0
This was dropped in upstream commit fd4fe7d129cac2b7a0668847117775ee23031771. See https://github.com/rust-lang/rust/pull/125880. rust-demangler is no more. For rust-bin *only*, USE=profiler was just used to control rust-demangler, not whether rust-bin was built with the profiler runtime (obviously), so we drop the USE flag for rust-bin. Bug: https://bugs.gentoo.org/939701 Closes: https://bugs.gentoo.org/939669 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/rust-bin')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.81.0.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.81.0.ebuild b/dev-lang/rust-bin/rust-bin-1.81.0.ebuild
index e51aa66a54b1..bf78998761f4 100644
--- a/dev-lang/rust-bin/rust-bin-1.81.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.81.0.ebuild
@@ -38,7 +38,7 @@ SRC_URI+=" ppc64? ( elibc_musl? (
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="stable"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix profiler rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
@@ -116,7 +116,6 @@ multilib_src_install() {
local components="rustc,cargo,${std}"
use doc && components="${components},rust-docs"
use clippy && components="${components},clippy-preview"
- use profiler && components="${components},rust-demangler-preview"
use rustfmt && components="${components},rustfmt-preview"
use rust-analyzer && components="${components},rust-analyzer-preview,${analysis}"
# Rust component 'rust-src' is extracted from separate archive
@@ -154,7 +153,6 @@ multilib_src_install() {
)
use clippy && symlinks+=( clippy-driver cargo-clippy )
- use profiler && symlinks+=( rust-demangler )
use rustfmt && symlinks+=( rustfmt cargo-fmt )
use rust-analyzer && symlinks+=( rust-analyzer )
@@ -202,9 +200,6 @@ multilib_src_install() {
echo /usr/bin/clippy-driver >> "${T}/provider-${P}"
echo /usr/bin/cargo-clippy >> "${T}/provider-${P}"
fi
- if use profiler; then
- echo /usr/bin/rust-demangler >> "${T}/provider-${P}"
- fi
if use rustfmt; then
echo /usr/bin/rustfmt >> "${T}/provider-${P}"
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"