summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-15 17:56:44 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-15 17:56:50 +0100
commitfd507906af65de2f31f8acd63366318a51658168 (patch)
treee9e6576bdb39252ade29b83b73efe5efc55cda9f /dev-lang/spidermonkey
parentgames-roguelike/tomenet: drop old (diff)
downloadgentoo-fd507906af65de2f31f8acd63366318a51658168.tar.gz
gentoo-fd507906af65de2f31f8acd63366318a51658168.tar.bz2
gentoo-fd507906af65de2f31f8acd63366318a51658168.zip
dev-lang/spidermonkey: relax llvm_check_deps
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/spidermonkey')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild b/dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild
index e950feecaffa..84db6ea9778a 100644
--- a/dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-78.6.0.ebuild
@@ -113,16 +113,18 @@ RDEPEND="${CDEPEND}"
S="${WORKDIR}/firefox-${MY_PV}/js/src"
llvm_check_deps() {
- if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
- ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
- return 1
- fi
-
- if use clang && use lto ; then
- if ! has_version -b "=sys-devel/lld-${LLVM_SLOT}*" ; then
- ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if use clang ; then
+ if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
+ ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
+
+ if use lto ; then
+ if ! has_version -b "=sys-devel/lld-${LLVM_SLOT}*" ; then
+ ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ return 1
+ fi
+ fi
fi
einfo "Using LLVM slot ${LLVM_SLOT} to build" >&2