summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-06 00:53:32 +0100
committerSam James <sam@gentoo.org>2023-04-06 01:31:47 +0100
commit82692290c64f6dd2f11f25625489dab7f7749fab (patch)
tree05a1f36846978f0e8d764a46719d4dd77cb3b8f9 /dev-lang
parentdev-lang/python: skip test_tools for PGO (diff)
downloadgentoo-82692290c64f6dd2f11f25625489dab7f7749fab.tar.gz
gentoo-82692290c64f6dd2f11f25625489dab7f7749fab.tar.bz2
gentoo-82692290c64f6dd2f11f25625489dab7f7749fab.zip
dev-lang/python: add timeout for PGO task for >= 3.10
Add a timeout matching the upstream default PROFILE_TASK given how often we've seen hangs here. Bug: https://bugs.gentoo.org/828535 Bug: https://bugs.gentoo.org/850154 Bug: https://bugs.gentoo.org/900429 Bug: https://bugs.gentoo.org/903890 Thanks-to: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.11.ebuild7
-rw-r--r--dev-lang/python/python-3.11.3.ebuild7
-rw-r--r--dev-lang/python/python-3.12.0_alpha7.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/dev-lang/python/python-3.10.11.ebuild b/dev-lang/python/python-3.10.11.ebuild
index 0e9df1369b1b..36d2fa653fd4 100644
--- a/dev-lang/python/python-3.10.11.ebuild
+++ b/dev-lang/python/python-3.10.11.ebuild
@@ -180,9 +180,14 @@ src_configure() {
-m test
"-j$(makeopts_jobs)"
--pgo-extended
- -x test_gdb
-u-network
+ # We use a timeout because of how often we've had hang issues
+ # here. It also matches the default upstream PROFILE_TASK.
+ --timeout 1200
+
+ -x test_gdb
+
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
diff --git a/dev-lang/python/python-3.11.3.ebuild b/dev-lang/python/python-3.11.3.ebuild
index 83f671a8ef6f..f575d640f0dd 100644
--- a/dev-lang/python/python-3.11.3.ebuild
+++ b/dev-lang/python/python-3.11.3.ebuild
@@ -167,9 +167,14 @@ src_configure() {
-m test
"-j$(makeopts_jobs)"
--pgo-extended
- -x test_gdb
-u-network
+ # We use a timeout because of how often we've had hang issues
+ # here. It also matches the default upstream PROFILE_TASK.
+ --timeout 1200
+
+ -x test_gdb
+
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
diff --git a/dev-lang/python/python-3.12.0_alpha7.ebuild b/dev-lang/python/python-3.12.0_alpha7.ebuild
index 94d6f02c4f80..d5837ceffb0c 100644
--- a/dev-lang/python/python-3.12.0_alpha7.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha7.ebuild
@@ -162,9 +162,14 @@ src_configure() {
-m test
"-j$(makeopts_jobs)"
--pgo-extended
- -x test_gdb
-u-network
+ # We use a timeout because of how often we've had hang issues
+ # here. It also matches the default upstream PROFILE_TASK.
+ --timeout 1200
+
+ -x test_gdb
+
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)