summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-09-30 20:02:53 +0200
committerDavid Seifert <soap@gentoo.org>2024-09-30 20:02:53 +0200
commitc2bd711b28713bbd9cd476757a8ea8ba7331e428 (patch)
tree01282dd785d5dc6b63010660c6142aba4008be07 /dev-libs/boost
parentsys-kernel/gentoo-sources: add 6.11.1 and dtrace patch p1 (diff)
downloadgentoo-c2bd711b28713bbd9cd476757a8ea8ba7331e428.tar.gz
gentoo-c2bd711b28713bbd9cd476757a8ea8ba7331e428.tar.bz2
gentoo-c2bd711b28713bbd9cd476757a8ea8ba7331e428.zip
dev-libs/boost: add boost.compute patch
Bug: https://bugs.gentoo.org/940042 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.86.0-r1.ebuild (renamed from dev-libs/boost/boost-1.86.0.ebuild)4
-rw-r--r--dev-libs/boost/files/boost-1.86.0-uuid-compute-backport.patch30
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/boost/boost-1.86.0.ebuild b/dev-libs/boost/boost-1.86.0-r1.ebuild
index 93350d1a6c7c..fc1acbc2b0ee 100644
--- a/dev-libs/boost/boost-1.86.0.ebuild
+++ b/dev-libs/boost/boost-1.86.0-r1.ebuild
@@ -52,6 +52,10 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.79.0-build-auto_index-tool.patch
"${FILESDIR}"/${PN}-1.85.0-bcp-filesystem.patch
"${FILESDIR}"/${PN}-1.85.0-python-numpy-2.patch
+
+ # backports
+ # https://github.com/boostorg/compute/issues/889
+ "${FILESDIR}"/${PN}-1.86.0-uuid-compute-backport.patch
)
create_user-config.jam() {
diff --git a/dev-libs/boost/files/boost-1.86.0-uuid-compute-backport.patch b/dev-libs/boost/files/boost-1.86.0-uuid-compute-backport.patch
new file mode 100644
index 000000000000..9fcf80680989
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.86.0-uuid-compute-backport.patch
@@ -0,0 +1,30 @@
+From 4ab28f5b879c8a2335b851f5338b9012f4466dd0 Mon Sep 17 00:00:00 2001
+From: sehe <github@sehe.nl>
+Date: Mon, 19 Aug 2024 17:42:31 +0200
+Subject: [PATCH] Update sha1.hpp for breaking interface change in Boost.UUID
+
+see https://github.com/boostorg/uuid/commit/0f843137a1a479797004f195ec615fdc6ac1c219
+---
+ boost/compute/detail/sha1.hpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/boost/compute/detail/sha1.hpp b/boost/compute/detail/sha1.hpp
+index 5afe5f9c4..24fde3cd1 100644
+--- a/boost/compute/detail/sha1.hpp
++++ b/boost/compute/detail/sha1.hpp
+@@ -37,12 +37,12 @@ class sha1 {
+ }
+
+ operator std::string() {
+- unsigned int digest[5];
++ unsigned char digest[20];
+ h.get_digest(digest);
+
+ std::ostringstream buf;
+- for(int i = 0; i < 5; ++i)
+- buf << std::hex << std::setfill('0') << std::setw(8) << digest[i];
++ for(int i = 0; i < 20; ++i)
++ buf << std::hex << std::setfill('0') << std::setw(2) << static_cast<int>(digest[i]);
+
+ return buf.str();
+ }