summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-01-31 08:17:24 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-02-03 08:37:53 +0200
commita0111536f393cd3776de329f52d1f3b2ce5dfec4 (patch)
tree09d704cbd903bb6b09cac0ff2bba685741e449fc /dev-libs/concurrencykit/files
parentnet-im/telegram-desktop-bin: Bump version to 1.9.9 (diff)
downloadgentoo-a0111536f393cd3776de329f52d1f3b2ce5dfec4.tar.gz
gentoo-a0111536f393cd3776de329f52d1f3b2ce5dfec4.tar.bz2
gentoo-a0111536f393cd3776de329f52d1f3b2ce5dfec4.zip
dev-libs/concurrencykit: bump to 0.7.0
Closes: https://bugs.gentoo.org/696418 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/concurrencykit/files')
-rw-r--r--dev-libs/concurrencykit/files/concurrencykit-doc.patch24
-rw-r--r--dev-libs/concurrencykit/files/concurrencykit-glibc-2.30.patch37
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/concurrencykit/files/concurrencykit-doc.patch b/dev-libs/concurrencykit/files/concurrencykit-doc.patch
new file mode 100644
index 000000000000..40aa466bb4e6
--- /dev/null
+++ b/dev-libs/concurrencykit/files/concurrencykit-doc.patch
@@ -0,0 +1,24 @@
+diff --git a/doc/Makefile.in b/doc/Makefile.in
+index cbad704..f476925 100644
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -1,7 +1,7 @@
+ .PHONY: clean install uninstall
+
+ MANDIR=@MANDIR@
+-GZIP=@GZIP@
++GZIP=/bin/echo
+ GZIP_SUFFIX=.3@GZIP_SUFFIX@
+ BUILD_DIR=@BUILD_DIR@
+ SRC_DIR=@SRC_DIR@
+@@ -206,7 +206,9 @@ refcheck:
+
+ install:
+ mkdir -p $(DESTDIR)/$(MANDIR)/man3 || exit
+- cp *$(GZIP_SUFFIX) $(DESTDIR)/$(MANDIR)/man3 || exit
++ for target in $(OBJECTS); do \
++ cp -v $$target $(DESTDIR)/$(MANDIR)/man3/$$target.3 || exit; \
++ done
+
+ uninstall:
+ for target in $(OBJECTS); do \
diff --git a/dev-libs/concurrencykit/files/concurrencykit-glibc-2.30.patch b/dev-libs/concurrencykit/files/concurrencykit-glibc-2.30.patch
new file mode 100644
index 000000000000..452421c63125
--- /dev/null
+++ b/dev-libs/concurrencykit/files/concurrencykit-glibc-2.30.patch
@@ -0,0 +1,37 @@
+diff --git a/regressions/common.h b/regressions/common.h
+index 6e53483d..9cdc690a 100644
+--- a/regressions/common.h
++++ b/regressions/common.h
+@@ -267,13 +267,11 @@ struct affinity {
+ #define AFFINITY_INITIALIZER {0, 0}
+
+ #ifdef __linux__
+-#ifndef gettid
+ static pid_t
+-gettid(void)
++common_gettid(void)
+ {
+ return syscall(__NR_gettid);
+ }
+-#endif /* gettid */
+
+ CK_CC_UNUSED static int
+ aff_iterate(struct affinity *acb)
+@@ -285,7 +283,7 @@ aff_iterate(struct affinity *acb)
+ CPU_ZERO(&s);
+ CPU_SET(c % CORES, &s);
+
+- if (sched_setaffinity(gettid(), sizeof(s), &s) != 0)
++ if (sched_setaffinity(common_gettid(), sizeof(s), &s) != 0)
+ perror("WARNING: Could not affine thread");
+
+ return 0;
+@@ -300,7 +298,7 @@ aff_iterate_core(struct affinity *acb, unsigned int *core)
+ CPU_ZERO(&s);
+ CPU_SET((*core) % CORES, &s);
+
+- if (sched_setaffinity(gettid(), sizeof(s), &s) != 0)
++ if (sched_setaffinity(common_gettid(), sizeof(s), &s) != 0)
+ perror("WARNING: Could not affine thread");
+
+ return 0;