summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-05-05 17:33:53 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-05-05 17:34:24 +0200
commit62601511e80a9c080934c2f74ff2ebd15faefab2 (patch)
treebe1f4cc9c0008144c4057aa93c345231d32943c1 /dev-libs/grok/files
parentsys-devel/clang-runtime: Bump to 5.0.2 (diff)
downloadgentoo-62601511e80a9c080934c2f74ff2ebd15faefab2.tar.gz
gentoo-62601511e80a9c080934c2f74ff2ebd15faefab2.tar.bz2
gentoo-62601511e80a9c080934c2f74ff2ebd15faefab2.zip
dev-libs/grok: Fix build with glibc-2.26, bug 638372
Also fix libdir, bug 628048 This still needs stabilization together with glibc-2.26. Closes: https://bugs.gentoo.org/628048 Bug: https://bugs.gentoo.org/638372 Package-Manager: Portage-2.3.33, Repoman-2.3.9
Diffstat (limited to 'dev-libs/grok/files')
-rw-r--r--dev-libs/grok/files/grok-0.9.2-libdir.patch28
-rw-r--r--dev-libs/grok/files/grok-0.9.2-libtirpc.patch21
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/grok/files/grok-0.9.2-libdir.patch b/dev-libs/grok/files/grok-0.9.2-libdir.patch
new file mode 100644
index 000000000000..06b19555cde8
--- /dev/null
+++ b/dev-libs/grok/files/grok-0.9.2-libdir.patch
@@ -0,0 +1,28 @@
+diff -ruN grok-0.9.2.orig/Makefile grok-0.9.2/Makefile
+--- grok-0.9.2.orig/Makefile 2018-05-05 17:26:35.451938040 +0200
++++ grok-0.9.2/Makefile 2018-05-05 17:29:03.414780593 +0200
+@@ -93,12 +93,12 @@
+
+ install: libgrok.$(LIBSUFFIX) grok discogrok $(GROKHEADER)
+ install -d $(DESTDIR)$(PREFIX)/bin
+- install -d $(DESTDIR)$(PREFIX)/lib
++ install -d $(DESTDIR)$(PREFIX)/$(LIBDIR)
+ install -d $(DESTDIR)$(PREFIX)/include
+ install -m 755 grok $(DESTDIR)$(PREFIX)/bin
+ install -m 755 discogrok $(DESTDIR)$(PREFIX)/bin
+- install -m 644 libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib
+- ln -s libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib/libgrok.$(LIBSUFFIX).1
++ install -m 644 libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/$(LIBDIR)
++ ln -s libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/$(LIBDIR)/libgrok.$(LIBSUFFIX).1
+ for header in $(GROKHEADER); do \
+ install -m 644 $$header $(DESTDIR)$(PREFIX)/include; \
+ done
+@@ -109,7 +109,7 @@
+ uninstall:
+ rm -f $(DESTDIR)$(PREFIX)/bin/grok
+ rm -f $(DESTDIR)$(PREFIX)/bin/discogrok
+- rm -f $(DESTDIR)$(PREFIX)/lib/libgrok.$(LIBSUFFIX)
++ rm -f $(DESTDIR)$(PREFIX)/$(LIBDIR)/libgrok.$(LIBSUFFIX)
+ for header in $(GROKHEADER); do \
+ rm -f $(DESTDIR)$(PREFIX)/include/$$header; \
+ done
diff --git a/dev-libs/grok/files/grok-0.9.2-libtirpc.patch b/dev-libs/grok/files/grok-0.9.2-libtirpc.patch
new file mode 100644
index 000000000000..0e91d9fed122
--- /dev/null
+++ b/dev-libs/grok/files/grok-0.9.2-libtirpc.patch
@@ -0,0 +1,21 @@
+diff -ruN grok-0.9.2.orig/Makefile grok-0.9.2/Makefile
+--- grok-0.9.2.orig/Makefile 2018-05-05 17:22:33.122558130 +0200
++++ grok-0.9.2/Makefile 2018-05-05 17:24:29.554221133 +0200
+@@ -25,7 +25,7 @@
+ GPERF?=/usr/bin/gperf
+ endif
+
+-LIBS=-lpcre -levent -rdynamic -ltokyocabinet
++LIBS=-lpcre -levent -rdynamic -ltokyocabinet -ltirpc
+
+ # For linux, we need libdl for dlopen()
+ # On FreeBSD, comment this line out.
+@@ -55,7 +55,7 @@
+ #LDFLAGS+=-L/usr/local/lib
+
+ # Platform so we know what to dlopen
+-CFLAGS+=-DPLATFORM_$(PLATFORM)
++CFLAGS+=-DPLATFORM_$(PLATFORM) -I/usr/include/tirpc
+ # Uncomment to totally disable logging features
+ #CFLAGS+=-DNOLOGGING
+