summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-05-22 15:42:58 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-05-22 15:43:58 +0200
commit6cec5ed8f017a8d6869deaa00c6a364f2230d209 (patch)
tree584b34aec0e8c412e07b9e15b0c840ac6d26469e /dev-libs/grok/grok-0.9.2-r1.ebuild
parentdev-libs/grok: Fix compilation against PCRE >=8.34 (diff)
downloadgentoo-6cec5ed8f017a8d6869deaa00c6a364f2230d209.tar.gz
gentoo-6cec5ed8f017a8d6869deaa00c6a364f2230d209.tar.bz2
gentoo-6cec5ed8f017a8d6869deaa00c6a364f2230d209.zip
dev-libs/grok: Rev bump to allow building against >=gperf-3.1
Closes: https://github.com/jordansissel/grok/issues/29 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-libs/grok/grok-0.9.2-r1.ebuild')
-rw-r--r--dev-libs/grok/grok-0.9.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/grok/grok-0.9.2-r1.ebuild b/dev-libs/grok/grok-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..8aceb1eb0a02
--- /dev/null
+++ b/dev-libs/grok/grok-0.9.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="DRY and RAD for regular expressions"
+HOMEPAGE="https://github.com/jordansissel/grok https://code.google.com/p/semicomplete/wiki/Grok"
+SRC_URI="https://github.com/jordansissel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+
+IUSE=""
+
+CDEPEND="dev-db/tokyocabinet
+ >=dev-libs/libevent-1.3:=
+ >=dev-libs/libpcre-7.6"
+
+RDEPEND="${CDEPEND}"
+DEPEND="${CDEPEND}
+ >=dev-util/gperf-3.1"
+
+PATCHES=(
+ "${FILESDIR}"/grok-0.9.2-Makefile.patch
+ "${FILESDIR}"/0.9.2-build-with-pcre-lt-8.34.patch
+ "${FILESDIR}"/grok-0.9.2-build-with-gperf-3.1.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}