summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-06-24 01:13:58 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-06-24 23:35:44 +0200
commita63e08e27a2cab3461555f61cd171d90afda237e (patch)
tree6eac3ecbdd5ca8a01a013e3e3cfdda265b9e5a4b /dev-libs/intel-compute-runtime
parentdev-libs/intel-compute-runtime: amd64 stable (diff)
downloadgentoo-a63e08e27a2cab3461555f61cd171d90afda237e.tar.gz
gentoo-a63e08e27a2cab3461555f61cd171d90afda237e.tar.bz2
gentoo-a63e08e27a2cab3461555f61cd171d90afda237e.zip
dev-libs/intel-compute-runtime: drop 23.13.26032.26
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-23.13.26032.26.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 0d585aedc090..36f70acede77 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,2 +1 @@
-DIST intel-compute-runtime-23.13.26032.26.tar.gz 6487863 BLAKE2B a483ea321f905fe61bbefed52b7c1505c5e00b82625092066800cd7064d635b667da31938c9d2ae2e4627ec2332732f6cff2feb1187c1773d96b38a8ae9bc341 SHA512 c552ddceac5385883949c0e3f58ea27cfa766a6fafdf8928775ae1bc601cf8dc8274fddbd98ffc36d3fcf61bfdd40bac5a51d07d072dc313cdcfc49382dbcc66
DIST intel-compute-runtime-23.17.26241.15.tar.gz 6556461 BLAKE2B 3814d5d24b0a79ebadda0f3ee5d1d3b414e9fb26e8c693ba66449a9f0500c8ec2e11533aa02142757e5177ad4c5efc5dd61a9c7db5a883a2cf4e9faab599ab4b SHA512 bd648fa964a15df76d1694af138f7c383239ccc5061cdd7faac0c45da3cffe95441614026b9bddfb86790446042ccc1d4abc3ecc023c50a036835598076a77bb
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.13.26032.26.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-23.13.26032.26.ebuild
deleted file mode 100644
index 893db4b58b43..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.13.26032.26.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND=">=media-libs/gmmlib-22.3.5:="
-
-DEPEND="
- ${DEPEND}
- dev-libs/intel-metrics-discovery:=
- dev-libs/intel-metrics-library:=
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.13860.4
- >=dev-util/intel-graphics-system-controller-0.8.7:=
- media-libs/mesa
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.11.0:= )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- media-libs/libva
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-PATCHES=(
- "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch"
-)
-
-src_prepare() {
- # Remove '-Werror' from default
- sed -e '/Werror/d' -i CMakeLists.txt || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # See https://github.com/intel/compute-runtime/issues/531
- filter-lto
-
- local mycmakeargs=(
- -DCCACHE_ALLOWED="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
- -Wno-dev
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
- )
-
- cmake_src_configure
-}