summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-10-24 08:58:29 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-10-24 09:02:01 +0300
commit0b8b6eb2f76a1c148f22ab6eb0a2e4cc053c8897 (patch)
tree9e01a7ecfecd17fa23e7341b7b4f852bf19e6269 /dev-libs/jemalloc
parentdev-lang/spidermonkey: drop 102.3.0 (diff)
downloadgentoo-0b8b6eb2f76a1c148f22ab6eb0a2e4cc053c8897.tar.gz
gentoo-0b8b6eb2f76a1c148f22ab6eb0a2e4cc053c8897.tar.bz2
gentoo-0b8b6eb2f76a1c148f22ab6eb0a2e4cc053c8897.zip
dev-libs/jemalloc: drop 5.3.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/jemalloc')
-rw-r--r--dev-libs/jemalloc/jemalloc-5.3.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-libs/jemalloc/jemalloc-5.3.0.ebuild b/dev-libs/jemalloc/jemalloc-5.3.0.ebuild
deleted file mode 100644
index 93e652a0edc9..000000000000
--- a/dev-libs/jemalloc/jemalloc-5.3.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
-HOMEPAGE="http://jemalloc.net/ https://github.com/jemalloc/jemalloc"
-SRC_URI="https://github.com/jemalloc/jemalloc/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0/2"
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-KEYWORDS="amd64 arm arm64 hppa ~loong ~m68k ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="debug lazy-lock prof stats xmalloc"
-HTML_DOCS=( doc/jemalloc.html )
-PATCHES=( "${FILESDIR}/${PN}-5.3.0-gentoo-fixups.patch" )
-
-MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-multilib_src_configure() {
- local myconf=(
- $(use_enable debug)
- $(use_enable lazy-lock)
- $(use_enable prof)
- $(use_enable stats)
- $(use_enable xmalloc)
- )
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-}
-
-multilib_src_install() {
- # Copy man file which the Makefile looks for
- cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
- emake DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fixup install_name, #437362
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.2.dylib \
- "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
- fi
- find "${ED}" -name '*.a' -delete || die
-}