summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancisco Blas (klondike) Izquierdo Riera <klondike@gentoo.org>2020-07-13 19:22:39 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-24 15:03:32 +0300
commit7faeb8c0bc3d122a4e4facc2d922246d9b9ef2c9 (patch)
treef52ae427d6ac78f24efe51c1dfb853e4b5d28247 /dev-libs/json-c
parentdev-haskell/cryptonite: Change USE to cpu_flags_x86_rdrand (diff)
downloadgentoo-7faeb8c0bc3d122a4e4facc2d922246d9b9ef2c9.tar.gz
gentoo-7faeb8c0bc3d122a4e4facc2d922246d9b9ef2c9.tar.bz2
gentoo-7faeb8c0bc3d122a4e4facc2d922246d9b9ef2c9.zip
dev-libs/json-c: Change USE to cpu_flags_x86_rdrand
Closes: https://bugs.gentoo.org/724354 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Francisco Blas Izquierdo Riera (klondike) <klondike@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/16686 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/json-c')
-rw-r--r--dev-libs/json-c/json-c-0.14-r3.ebuild4
-rw-r--r--dev-libs/json-c/json-c-9999.ebuild4
-rw-r--r--dev-libs/json-c/metadata.xml3
3 files changed, 4 insertions, 7 deletions
diff --git a/dev-libs/json-c/json-c-0.14-r3.ebuild b/dev-libs/json-c/json-c-0.14-r3.ebuild
index 0d4ff648a369..0eae66557750 100644
--- a/dev-libs/json-c/json-c-0.14-r3.ebuild
+++ b/dev-libs/json-c/json-c-0.14-r3.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://s3.amazonaws.com/json-c_releases/releases/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/5"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="cpu-flags-x86-rdrand doc static-libs threads"
+IUSE="cpu_flags_x86_rdrand doc static-libs threads"
PATCHES=(
"${FILESDIR}/${PN}-0.14-cmake-static-libs.patch"
@@ -34,7 +34,7 @@ multilib_src_configure() {
-DBUILD_DOCUMENTATION=$(multilib_native_usex doc)
-DBUILD_STATIC_LIBS=$(usex static-libs)
-DDISABLE_WERROR=ON
- -DENABLE_RDRAND=$(usex cpu-flags-x86-rdrand)
+ -DENABLE_RDRAND=$(usex cpu_flags_x86_rdrand)
-DENABLE_THREADING=$(usex threads)
)
diff --git a/dev-libs/json-c/json-c-9999.ebuild b/dev-libs/json-c/json-c-9999.ebuild
index 51583e0b0ad4..b39b8ba779c5 100644
--- a/dev-libs/json-c/json-c-9999.ebuild
+++ b/dev-libs/json-c/json-c-9999.ebuild
@@ -12,7 +12,7 @@ EGIT_REPO_URI="https://github.com/json-c/json-c.git"
LICENSE="MIT"
SLOT="0/5"
-IUSE="cpu-flags-x86-rdrand doc static-libs threads"
+IUSE="cpu_flags_x86_rdrand doc static-libs threads"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/json-c/config.h
@@ -27,7 +27,7 @@ multilib_src_configure() {
-DBUILD_DOCUMENTATION=$(multilib_native_usex doc)
-DDISABLE_WERROR=ON
-DENABLE_THREADING=$(usex threads)
- -DENABLE_RDRAND=$(usex cpu-flags-x86-rdrand)
+ -DENABLE_RDRAND=$(usex cpu_flags_x86_rdrand)
-DBUILD_STATIC_LIBS=$(usex static-libs)
)
diff --git a/dev-libs/json-c/metadata.xml b/dev-libs/json-c/metadata.xml
index 7f12c818ab4c..e822c83364dc 100644
--- a/dev-libs/json-c/metadata.xml
+++ b/dev-libs/json-c/metadata.xml
@@ -13,9 +13,6 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
- <use>
- <flag name="cpu-flags-x86-rdrand">Enable RDRAND Hardware RNG Hash Seed</flag>
- </use>
<longdescription lang="en">
JSON-C is a JSON implementation written in C. It implements a
reference counting object model that allows you to easily