summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-16 20:37:21 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-16 21:42:58 -0400
commit848a88bab444808a159ad83b9de32b1d21d74280 (patch)
tree633ab326394581d9870cdc8895758b43c57abcf2 /dev-libs/libdex/libdex-0.4.0.ebuild
parentgui-libs/gtksourceview: Version bump to 5.10.0 (diff)
downloadgentoo-848a88bab444808a159ad83b9de32b1d21d74280.tar.gz
gentoo-848a88bab444808a159ad83b9de32b1d21d74280.tar.bz2
gentoo-848a88bab444808a159ad83b9de32b1d21d74280.zip
dev-libs/libdex: Version bump to 0.4.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32861 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libdex/libdex-0.4.0.ebuild')
-rw-r--r--dev-libs/libdex/libdex-0.4.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/libdex/libdex-0.4.0.ebuild b/dev-libs/libdex/libdex-0.4.0.ebuild
new file mode 100644
index 000000000000..71b799ea6e23
--- /dev/null
+++ b/dev-libs/libdex/libdex-0.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala
+
+DESCRIPTION="Deferred Execution library for GNOME and GTK"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libdex"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk-doc +introspection sysprof test vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.68:2
+ >=sys-libs/liburing-0.7:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ sysprof? ( dev-util/sysprof-capture:4 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-util/glib-utils
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dexamples=false
+ $(meson_use vala vapi)
+ $(meson_feature introspection)
+ $(meson_use sysprof)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}-1 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}