summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-07-01 17:52:22 -0300
committerMatt Turner <mattst88@gentoo.org>2023-07-18 18:37:44 -0400
commitd2f4a9fc0eef6893f867570da65ccecf35d87c87 (patch)
treeb6a62df4970695239f8d5d721d46f3e188e0faaf /dev-libs/libdex
parentgnome-extra/gnome-software: Version bump to 45_alpha (diff)
downloadgentoo-d2f4a9fc0eef6893f867570da65ccecf35d87c87.tar.gz
gentoo-d2f4a9fc0eef6893f867570da65ccecf35d87c87.tar.bz2
gentoo-d2f4a9fc0eef6893f867570da65ccecf35d87c87.zip
dev-libs/libdex: Version bump to 0.3.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31694 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libdex')
-rw-r--r--dev-libs/libdex/Manifest1
-rw-r--r--dev-libs/libdex/libdex-0.3.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/libdex/Manifest b/dev-libs/libdex/Manifest
index b60b4a63c716..e62d47d2fae1 100644
--- a/dev-libs/libdex/Manifest
+++ b/dev-libs/libdex/Manifest
@@ -1 +1,2 @@
DIST libdex-0.2.0.tar.xz 91648 BLAKE2B 258193b29082024cce30d5e20903f1ba6a3c8e566652d341845178797126796fcc1cf628636de02ba9776cb9d8ff5d38c24f10f269fcd9acbc0cdbb1c0918d8b SHA512 db54fa974af97e59e7a21c19be73db8fec6565377ce313a3532435845d3571216d6617f9a8db500019390d85677ca6f30be3f9a36c60240c8130ae0834826a65
+DIST libdex-0.3.0.tar.xz 94572 BLAKE2B 1c5ac31b71b076592aeeec8a8005dc429495bd2ee00918d3a2b9d63a8f48b94f2b4bad1b09b5ebaeb7c1799e90e91e6d8c56cc92c4874ae247013d9bba9a489b SHA512 04093447a77e972074425acb38876c62473bf6f609938fa2d7ec36fc944972547c7e8bebfe279273f530f90e18c45ed190ccbf602846c0d783af7fd0c9ac08ce
diff --git a/dev-libs/libdex/libdex-0.3.0.ebuild b/dev-libs/libdex/libdex-0.3.0.ebuild
new file mode 100644
index 000000000000..f0d86d8a55dd
--- /dev/null
+++ b/dev-libs/libdex/libdex-0.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala
+
+DESCRIPTION="Deferred Execution library for GNOME and GTK"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libdex"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk-doc +introspection sysprof test vala"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.68:2
+ >=sys-libs/liburing-0.7:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ sysprof? ( dev-util/sysprof-capture:4 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-util/glib-utils
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dexamples=false
+ $(meson_use vala vapi)
+ $(meson_feature introspection)
+ -Dsysprof=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/${PN}-1 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+}