summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libelf/files/libelf-0.8.13-build.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libelf/files/libelf-0.8.13-build.patch')
-rw-r--r--dev-libs/libelf/files/libelf-0.8.13-build.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libelf/files/libelf-0.8.13-build.patch b/dev-libs/libelf/files/libelf-0.8.13-build.patch
new file mode 100644
index 000000000000..7e0cce6384d9
--- /dev/null
+++ b/dev-libs/libelf/files/libelf-0.8.13-build.patch
@@ -0,0 +1,38 @@
+Index: libelf-0.8.13/aclocal.m4
+===================================================================
+--- libelf-0.8.13.orig/aclocal.m4
++++ libelf-0.8.13/aclocal.m4
+@@ -235,7 +235,7 @@ AC_DEFUN(mr_ENABLE_SHARED, [
+ AC_REQUIRE([AC_PROG_CC])
+ AC_PATH_PROG(LD, ld, ld)
+ case "$host" in
+- *-linux*|*-gnu*)
++ *-linux*|*-gnu*|*-freebsd*|*-solaris*)
+ if test "$GCC" = yes; then
+ mr_TARGET_ELF
+ if test "$mr_cv_target_elf" = yes; then
+Index: libelf-0.8.13/lib/Makefile.in
+===================================================================
+--- libelf-0.8.13.orig/lib/Makefile.in
++++ libelf-0.8.13/lib/Makefile.in
+@@ -158,7 +158,7 @@ libelf.a: $(OBJS) $(LIBOBJS)
+
+ $(SHLIB): libelf.a
+ @$(RM) $(SHLIB)
+- $(LINK_SHLIB) -o $(SHLIB) $(OBJS:.o=.os) $(LIBOBJS:.o=.os) $(DEPSHLIBS)
++ $(LINK_SHLIB) $(LDFLAGS) -o $(SHLIB) $(OBJS:.o=.os) $(LIBOBJS:.o=.os) $(DEPSHLIBS)
+ if test "$(SONAME)" = "$(SHLIB)"; then true; else \
+ $(RM) $(SONAME) && $(LN_S) $(SHLIB) $(SONAME); \
+ fi
+@@ -169,9 +169,9 @@ $(SHLIB): libelf.a
+ install: install-data \
+ install-shared-$(DO_SHLIB) install-compat-$(DO_COMPAT)
+
+-installdirs: $(top_srcdir)/mkinstalldirs
++installdirs:
+ dirs="$(installdirs)"; for dir in $$dirs; do \
+- $(SHELL) $(top_srcdir)/mkinstalldirs $(instroot)$$dir; \
++ mkdir -p $(instroot)$$dir; \
+ done
+
+ install-data: all installdirs