summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-10-30 15:55:33 -0700
committerMatt Turner <mattst88@gentoo.org>2018-10-30 15:56:32 -0700
commit83bec912d817b1b95967aabef1bf247599ffe594 (patch)
tree187b815dd2eb57efec381acdad976793f0d6dc5c /dev-libs/libevdev
parentsys-kernel/gentoo-sources: Linux patch 4.4.162 (diff)
downloadgentoo-83bec912d817b1b95967aabef1bf247599ffe594.tar.gz
gentoo-83bec912d817b1b95967aabef1bf247599ffe594.tar.bz2
gentoo-83bec912d817b1b95967aabef1bf247599ffe594.zip
dev-libs/libevdev: Version bump to 1.6.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libevdev')
-rw-r--r--dev-libs/libevdev/Manifest1
-rw-r--r--dev-libs/libevdev/libevdev-1.6.0.ebuild48
-rw-r--r--dev-libs/libevdev/libevdev-9999.ebuild2
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-libs/libevdev/Manifest b/dev-libs/libevdev/Manifest
index 85c9c97a52a8..3a162eb67bc1 100644
--- a/dev-libs/libevdev/Manifest
+++ b/dev-libs/libevdev/Manifest
@@ -1 +1,2 @@
DIST libevdev-1.5.9.tar.xz 408200 BLAKE2B b99974eab572693c9e2a915b21adf2e6c09e26af70011ce661084ac9add51cb6257f36bcfeb89d76c8987cf8724e69b027d30eda17c4457a40f3e047302efa19 SHA512 4496ab4d9dc165f416a574c21a7fcee54ae104c21ef4785a4dd0311fff428020cdbb5da7bf3f835e78dae05effdb1a557d189347f6e62dd6be2d8bcdc845850c
+DIST libevdev-1.6.0.tar.xz 411512 BLAKE2B 0e9190fd4c28b36bcf325953aa634c0d8c604cef7f56e46679fc88351536d78b0bddedbbdfffe4164e0039c7d56ef604b143e23de2c4bb9a66653a03d6844fa9 SHA512 73046da447773716c9f0c9f511f3a0a6ababcf92a146eba363014afcbdb465f4c3cd8be0917f2f01561a72f24f20fe8ecd333467437d9d85c03afcb433d05060
diff --git a/dev-libs/libevdev/libevdev-1.6.0.ebuild b/dev-libs/libevdev/libevdev-1.6.0.ebuild
new file mode 100644
index 000000000000..2f3e3b8ac97a
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit multilib-minimal python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libevdev.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc static-libs"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+RESTRICT="test" # Tests need to run as root.
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999* ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ if use doc ;then
+ local HTML_DOCS=( doc/html/. )
+ einstalldocs
+ fi
+}
diff --git a/dev-libs/libevdev/libevdev-9999.ebuild b/dev-libs/libevdev/libevdev-9999.ebuild
index d551ca6aecf2..2f3e3b8ac97a 100644
--- a/dev-libs/libevdev/libevdev-9999.ebuild
+++ b/dev-libs/libevdev/libevdev-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7