summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-02 16:18:26 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-02 16:18:42 +0100
commit9562bcbde92483f01acbc86bddffa2861302a010 (patch)
tree156dac0b61fc138d9a9bc45fd9bffaa9eddd23b2 /dev-libs/libevent/libevent-2.1.8.ebuild
parentapp-crypt/argon2: Fix "static-libs" usage (diff)
downloadgentoo-9562bcbde92483f01acbc86bddffa2861302a010.tar.gz
gentoo-9562bcbde92483f01acbc86bddffa2861302a010.tar.bz2
gentoo-9562bcbde92483f01acbc86bddffa2861302a010.zip
dev-libs/libevent: Add USE=malloc-replacement (bug #545358).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libevent/libevent-2.1.8.ebuild')
-rw-r--r--dev-libs/libevent/libevent-2.1.8.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-libs/libevent/libevent-2.1.8.ebuild b/dev-libs/libevent/libevent-2.1.8.ebuild
index ca87a245997e..b5b65d93a194 100644
--- a/dev-libs/libevent/libevent-2.1.8.ebuild
+++ b/dev-libs/libevent/libevent-2.1.8.ebuild
@@ -13,7 +13,7 @@ LICENSE="BSD"
# libevent-2.1.so.6
SLOT="0/2.1-6"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug libressl +ssl static-libs test +threads"
+IUSE="debug libressl +malloc-replacement +ssl static-libs test +threads"
DEPEND="
ssl? (
@@ -43,13 +43,14 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \
- --disable-samples \
$(use_enable debug debug-mode) \
$(use_enable debug malloc-replacement) \
+ $(use_enable malloc-replacement) \
$(use_enable ssl openssl) \
$(use_enable static-libs static) \
$(use_enable test libevent-regress) \
- $(use_enable threads thread-support)
+ $(use_enable threads thread-support) \
+ --disable-samples
}
src_test() {