summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-09-19 08:29:10 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-09-19 08:29:50 +0100
commit8cd14f3d80746f350e6ffd103cb1f4629c625f2f (patch)
tree43d688b0ff284d63c5e8865f075ee47fb565902b /dev-libs/libffi
parentnet-mail/notmuch: drop gpgme hack, it's a dep problem (diff)
downloadgentoo-8cd14f3d80746f350e6ffd103cb1f4629c625f2f.tar.gz
gentoo-8cd14f3d80746f350e6ffd103cb1f4629c625f2f.tar.bz2
gentoo-8cd14f3d80746f350e6ffd103cb1f4629c625f2f.zip
dev-libs/libffi: backport emutramp fix to 3.2.1, bug #694916
Reported-by: spotlight@joscomputing.space Bug: https://bugs.gentoo.org/694916 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/libffi')
-rw-r--r--dev-libs/libffi/files/libffi-3.2.1-musl-emutramp.patch31
-rw-r--r--dev-libs/libffi/libffi-3.2.1-r3.ebuild70
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/libffi/files/libffi-3.2.1-musl-emutramp.patch b/dev-libs/libffi/files/libffi-3.2.1-musl-emutramp.patch
new file mode 100644
index 000000000000..7c011d2b6d07
--- /dev/null
+++ b/dev-libs/libffi/files/libffi-3.2.1-musl-emutramp.patch
@@ -0,0 +1,31 @@
+https://github.com/libffi/libffi/commit/e169ba2b83c780058fe626856cfdb5903a85cb97.patch
+https://bugs.gentoo.org/694916
+
+From e169ba2b83c780058fe626856cfdb5903a85cb97 Mon Sep 17 00:00:00 2001
+From: Kylie McClain <somasis@exherbo.org>
+Date: Fri, 29 Apr 2016 21:04:07 -0400
+Subject: [PATCH] Fix usage on musl libc
+
+A gcc compiled on musl does not define __gnu_linux__, it defines __linux__.
+Only on glibc does __gnu_linux__ get defined, but both define __linux__, so
+we should check for that instead.
+
+With this patch, libffi works perfectly, and passes its testsuite entirely
+on musl libc systems.
+---
+ src/closures.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/closures.c b/src/closures.c
+index 3dec0e31..05849e06 100644
+--- a/src/closures.c
++++ b/src/closures.c
+@@ -35,7 +35,7 @@
+ #include <ffi_common.h>
+
+ #if !FFI_MMAP_EXEC_WRIT && !FFI_EXEC_TRAMPOLINE_TABLE
+-# if __gnu_linux__ && !defined(__ANDROID__)
++# if __linux__ && !defined(__ANDROID__)
+ /* This macro indicates it may be forbidden to map anonymous memory
+ with both write and execute permission. Code compiled when this
+ option is defined will attempt to map such pages once, but if it
diff --git a/dev-libs/libffi/libffi-3.2.1-r3.ebuild b/dev-libs/libffi/libffi-3.2.1-r3.ebuild
new file mode 100644
index 000000000000..45d1209a70d6
--- /dev/null
+++ b/dev-libs/libffi/libffi-3.2.1-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils libtool multilib multilib-minimal toolchain-funcs
+
+DESCRIPTION="a portable, high level programming interface to various calling conventions"
+HOMEPAGE="https://sourceware.org/libffi/"
+SRC_URI="ftp://sourceware.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug pax_kernel static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-util/dejagnu )"
+
+DOCS="ChangeLog* README"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.1-o-tmpfile-eacces.patch #529044
+ "${FILESDIR}"/${PN}-3.2.1-complex_alpha.patch
+ "${FILESDIR}"/${PN}-3.1-darwin-x32.patch
+ "${FILESDIR}"/${PN}-3.2.1-complex-ia64.patch
+ "${FILESDIR}"/${PN}-3.2.1-include-path.patch
+ "${FILESDIR}"/${PN}-3.2.1-include-path-autogen.patch
+ "${FILESDIR}"/${PN}-3.2.1-ia64-small-struct.patch #634190
+ "${FILESDIR}"/${PN}-3.2.1-musl-emutramp.patch #694916
+)
+
+ECONF_SOURCE=${S}
+
+pkg_setup() {
+ # Check for orphaned libffi, see https://bugs.gentoo.org/354903 for example
+ if [[ ${ROOT} == "/" && ${EPREFIX} == "" ]] && ! has_version ${CATEGORY}/${PN}; then
+ local base="${T}"/conftest
+ echo 'int main() { }' > "${base}".c
+ $(tc-getCC) -o "${base}" "${base}".c -lffi >&/dev/null
+ if [ $? -eq 0 ]; then
+ eerror "The linker reported linking against -lffi to be working while it shouldn't have."
+ eerror "This is wrong and you should find and delete the old copy of libffi before continuing."
+ die "The system is in inconsistent state with unknown libffi installed."
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i -e 's:@toolexeclibdir@:$(libdir):g' Makefile.in || die #462814
+ elibtoolize
+}
+
+multilib_src_configure() {
+ use userland_BSD && export HOST="${CHOST}"
+ # python does not like miltilib-wrapped headers: bug #643582
+ # thus we install includes into ABI-specific paths
+ local includes="${EPREFIX}"/usr/$(get_libdir)/${P}/include/
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable pax_kernel pax_emutramp) \
+ $(use_enable debug) \
+ --includedir="${includes}"
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}