summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-10-05 12:42:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-10-05 12:42:38 +0200
commit1346f8c2ef6c78007bc0e41c771495aaaa217e17 (patch)
tree12e4f4b0be1be5698bae7578ce13e65f3e444dee /dev-libs/libgnt
parentsys-auth/polkit: Revbump to install files with required SUID bit again (diff)
downloadgentoo-1346f8c2ef6c78007bc0e41c771495aaaa217e17.tar.gz
gentoo-1346f8c2ef6c78007bc0e41c771495aaaa217e17.tar.bz2
gentoo-1346f8c2ef6c78007bc0e41c771495aaaa217e17.zip
dev-libs/libgnt: Bump to version 2.14.3
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libgnt')
-rw-r--r--dev-libs/libgnt/Manifest1
-rw-r--r--dev-libs/libgnt/libgnt-2.14.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libgnt/Manifest b/dev-libs/libgnt/Manifest
index d6cc4ec87d0e..083baebef04c 100644
--- a/dev-libs/libgnt/Manifest
+++ b/dev-libs/libgnt/Manifest
@@ -1,2 +1,3 @@
DIST libgnt-2.14.1.tar.xz 106564 BLAKE2B 19eddef51b44fa82982c705415fee43bf7495bc4692a7371fea782bcc21acdb932f15e1e8de6af962a529eea59f54c0b116d96b87ed3616201e6370760fac5b8 SHA512 434fff31a0946dabeaadbabaf96b4a7cf7f2a7da6d7794b7cf8a75f3f959388d89b32ce5921a20d5d6532ac2fd851ec2f6c18cc7cbc5a0ae97a00ff1ee3f74c3
DIST libgnt-2.14.2.tar.xz 106128 BLAKE2B d3db0ba3a297c14f32cc49b4e5b3392f47031e9406d862520a2f014f4d4e93c13e2ba5a2d61df81637f9dd7961d64ba69b393ee5b3cfebd7eb2768e3f16f29d0 SHA512 17b39e132b44b23486d7d39fa02761997a28abf53f67bf71bbad86d35124e5deb0363d670b2fb5ac99d47256282b0ef6ad1886e12984c868bb0d13ea7ba7d860
+DIST libgnt-2.14.3.tar.xz 106388 BLAKE2B bba785c998e53c75ed9c3b0b4ad1d96d63628a6e2b0ac7abec76a671ddfc0284fd787cd6793433aef83e6b31c6efecce0c656e131ca9b8bf548486de1010e1f9 SHA512 7131834cfe585177865bebf26167de08a04fced3da4e9a072d9b09b3becd1194914757b1a1fc8f129ae6c8fefe3ec1ce0d80d6c50cb624a5698b66ee2e06c6c8
diff --git a/dev-libs/libgnt/libgnt-2.14.3.ebuild b/dev-libs/libgnt/libgnt-2.14.3.ebuild
new file mode 100644
index 000000000000..b0ee4aa1f2cc
--- /dev/null
+++ b/dev-libs/libgnt/libgnt-2.14.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Pidgin's GLib Ncurses Toolkit"
+HOMEPAGE="https://keep.imfreedom.org/libgnt/libgnt"
+SRC_URI="mirror://sourceforge/pidgin/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ !<net-im/pidgin-2.14.0
+ dev-libs/glib:2
+ dev-libs/libxml2
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.14.0-tinfo.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dpython2=false
+ $(meson_use doc)
+ )
+ meson_src_configure
+}