summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libhome
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libhome')
-rw-r--r--dev-libs/libhome/Manifest1
-rw-r--r--dev-libs/libhome/files/libhome-0.10.2-Makefile.patch59
-rw-r--r--dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch12
-rw-r--r--dev-libs/libhome/libhome-0.10.2-r1.ebuild56
-rw-r--r--dev-libs/libhome/metadata.xml10
5 files changed, 138 insertions, 0 deletions
diff --git a/dev-libs/libhome/Manifest b/dev-libs/libhome/Manifest
new file mode 100644
index 000000000000..da7e52f7e2ef
--- /dev/null
+++ b/dev-libs/libhome/Manifest
@@ -0,0 +1 @@
+DIST libhome-0.10.2.tar.gz 286453 SHA256 a099e61e83c140d74e3515135881903f26358bc32ce97292c8a8c673e7c0de13 SHA512 9f144b6aeb8e01f5ca2f8f90c5289d4449895e2eddbfd2d8d9b1828bb203fd8f68c224c0f068ffabfa5ee1514f9b756cb2499f862418d793eb8d06ae960447a9 WHIRLPOOL 04db6d6406e9f4f715db2236fa48b2b1e5bc7e625cbfd1c0ac192fff58dac71bc4e9ef1dac6cdd4d8ab01beede31ecda7c9fac6ec239939ef061e576c0250b44
diff --git a/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch b/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
new file mode 100644
index 000000000000..54915fd4bb04
--- /dev/null
+++ b/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
@@ -0,0 +1,59 @@
+--- Makefile.in
++++ Makefile.in
+@@ -61,7 +61,7 @@
+ LIBTOOL=./libtool
+
+ COMPILE=${LIBTOOL} --mode=compile ${CC} ${CPPFLAGS} ${CFLAGS}
+-LINK=${LIBTOOL} --mode=link ${CC} ${CFLAGS}
++LINK=${LIBTOOL} --mode=link ${CC} ${CFLAGS} ${LDFLAGS}
+
+
+ hparam.o: version.h
+@@ -114,27 +114,32 @@
+ install:: install-man install-lib
+
+ install-man:: home.conf.5
+- ${INSTALL_DATA} home.conf.5 ${mandir}/man5/
+-@DO_PROXY@ ${INSTALL_DATA} home_proxy.8 ${mandir}/man8/
++ ${INSTALL} -d $(DESTDIR)${mandir}/man5
++@DO_PROXY@ ${INSTALL} -d $(DESTDIR)${mandir}/man8
++ ${INSTALL_DATA} home.conf.5 $(DESTDIR)${mandir}/man5/
++@DO_PROXY@ ${INSTALL_DATA} home_proxy.8 $(DESTDIR)${mandir}/man8/
+
+ install-lib:: all
+- ${LIBTOOL} --mode=install ${INSTALL_DATA} libhome.la ${libdir}/
++ ${INSTALL} -d $(DESTDIR)${libdir}
++ ${INSTALL} -d $(DESTDIR)${bindir}
++@DO_PROXY@ ${INSTALL} -d $(DESTDIR)${sbindir}
++ ${INSTALL} -d $(DESTDIR)${includedir}/home
++ ${LIBTOOL} --mode=install ${INSTALL_DATA} libhome.la $(DESTDIR)${libdir}/
+ test "@PRELOAD_LIB@" = "" || \
+- ${LIBTOOL} --mode=install ${INSTALL_DATA} @PRELOAD_LIB@ ${libdir}/
+- ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_finger ${bindir}/
+- ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_su ${bindir}/
+- -mkdir -p ${includedir}/home
+- ${INSTALL_DATA} hpwd.h ${includedir}/home/pwd.h
+- ${INSTALL_DATA} hpwd.h ${includedir}/home/
+- ${INSTALL_DATA} hparam.h ${includedir}/home/
+- ${INSTALL_DATA} home_version.h ${includedir}/home/
++ ${LIBTOOL} --mode=install ${INSTALL_DATA} @PRELOAD_LIB@ $(DESTDIR)${libdir}/
++ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_finger $(DESTDIR)${bindir}/
++ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_su $(DESTDIR)${bindir}/
++ ${INSTALL_DATA} -D hpwd.h $(DESTDIR)${includedir}/home/pwd.h
++ ${INSTALL_DATA} -D hpwd.h $(DESTDIR)${includedir}/home/
++ ${INSTALL_DATA} -D hparam.h $(DESTDIR)${includedir}/home/
++ ${INSTALL_DATA} -D home_version.h $(DESTDIR)${includedir}/home/
+ chmod +x libhome.sh
+- ${INSTALL_SCRIPT} libhome.sh ${bindir}/
+-@DO_PROXY@ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_proxy ${sbindir}/
+-@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} ${libdir}/
++ ${INSTALL_SCRIPT} -D libhome.sh $(DESTDIR)${bindir}/
++@DO_PROXY@ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_proxy $(DESTDIR)${sbindir}/
++@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} $(DESTDIR)${libdir}/
+
+ install-nss:: nss
+-@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} ${libdir}/
++@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} $(DESTDIR)${libdir}/
+
+ compat:
+ -mkdir compat
diff --git a/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch b/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch
new file mode 100644
index 000000000000..a96645176c13
--- /dev/null
+++ b/dev-libs/libhome/files/libhome-0.10.2-ldap_deprecated.patch
@@ -0,0 +1,12 @@
+Index: libhome-0.10.2/hldap.c
+===================================================================
+--- libhome-0.10.2.orig/hldap.c
++++ libhome-0.10.2/hldap.c
+@@ -27,6 +27,7 @@ static char const rcsid[] UNUSED =
+ "$Id: libhome-0.10.2-ldap_deprecated.patch,v 1.1 2009/07/05 19:25:41 hollow Exp $";
+
+ #define passwd system_passwd
++#define LDAP_DEPRECATED 1
+ #include <lber.h> /* for openldap 1.x */
+ #include <ldap.h>
+ #include <errno.h>
diff --git a/dev-libs/libhome/libhome-0.10.2-r1.ebuild b/dev-libs/libhome/libhome-0.10.2-r1.ebuild
new file mode 100644
index 000000000000..701c5c986cf8
--- /dev/null
+++ b/dev-libs/libhome/libhome-0.10.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools db-use eutils
+
+DESCRIPTION="libhome is a library providing a getpwnam() emulation"
+HOMEPAGE="http://pll.sourceforge.net"
+SRC_URI="mirror://sourceforge/pll/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb ldap mysql pam postgres"
+
+DEPEND="berkdb? ( >=sys-libs/db-4 )
+ ldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql[server] )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -f aclocal.m4
+
+ epatch "${FILESDIR}"/${PN}-0.10.2-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-0.10.2-ldap_deprecated.patch
+
+ # bug 225579
+ sed -i -e 's:\<VERSION\>:__PKG_VERSION:' configure.in
+
+ sed -i -e '/AC_SEARCH_LIBS.*db4/s: db-4.* db4:'$(db_libname)':' \
+ configure.in
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --without-db3 \
+ $(use_with berkdb db4 $(db_includedir)) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with pam) \
+ $(use_with postgres pgsql) \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/dev-libs/libhome/metadata.xml b/dev-libs/libhome/metadata.xml
new file mode 100644
index 000000000000..312dcb0c7d32
--- /dev/null
+++ b/dev-libs/libhome/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pll</remote-id>
+ </upstream>
+</pkgmetadata>