summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-07-10 18:47:42 -0400
committerMike Gilbert <floppym@gentoo.org>2023-07-10 18:47:42 -0400
commita9e38d26b4c391c4431a98cd9cb550c0247bdd00 (patch)
treebc7e548362227f81ffcc5fa0e023dfee9c2521f7 /dev-libs/libp11
parentdev-libs/libbpf: add 1.2.1 (diff)
downloadgentoo-a9e38d26b4c391c4431a98cd9cb550c0247bdd00.tar.gz
gentoo-a9e38d26b4c391c4431a98cd9cb550c0247bdd00.tar.bz2
gentoo-a9e38d26b4c391c4431a98cd9cb550c0247bdd00.zip
dev-libs/libp11: fix openssl-3.1 detection
Closes: https://bugs.gentoo.org/910203 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/libp11')
-rw-r--r--dev-libs/libp11/files/libp11-0.4.12-openssl-3.1.patch25
-rw-r--r--dev-libs/libp11/libp11-0.4.12-r3.ebuild (renamed from dev-libs/libp11/libp11-0.4.12-r2.ebuild)18
2 files changed, 40 insertions, 3 deletions
diff --git a/dev-libs/libp11/files/libp11-0.4.12-openssl-3.1.patch b/dev-libs/libp11/files/libp11-0.4.12-openssl-3.1.patch
new file mode 100644
index 000000000000..fbc7cf9d64ed
--- /dev/null
+++ b/dev-libs/libp11/files/libp11-0.4.12-openssl-3.1.patch
@@ -0,0 +1,25 @@
+https://github.com/OpenSC/libp11/pull/503
+https://bugs.gentoo.org/910203
+
+From 580c12b78b63d88010a6178d7c4c58186938c479 Mon Sep 17 00:00:00 2001
+From: Dominique Leuenberger <dimstar@opensuse.org>
+Date: Tue, 6 Jun 2023 14:27:46 +0200
+Subject: [PATCH] Detect openSSL 3.1; compatible to openSSL 3.0
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index d6b0ee91..b96979d9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,7 +33,7 @@ AC_C_BIGENDIAN
+ # issues with applications linking to new openssl, old libp11, and vice versa
+ case "`$PKG_CONFIG --modversion --silence-errors libcrypto || \
+ $PKG_CONFIG --modversion openssl`" in
+- 3.0.*) # Predicted engines directory prefix for OpenSSL 3.x
++ 3.1.*|3.0.*) # Predicted engines directory prefix for OpenSSL 3.x
+ LIBP11_LT_OLDEST="3"
+ debian_ssl_prefix="openssl-3.0.0";;
+ 1.1.*) # Predicted engines directory prefix for OpenSSL 1.1.x
diff --git a/dev-libs/libp11/libp11-0.4.12-r2.ebuild b/dev-libs/libp11/libp11-0.4.12-r3.ebuild
index 7b6e2ec011e6..83c149c404b1 100644
--- a/dev-libs/libp11/libp11-0.4.12-r2.ebuild
+++ b/dev-libs/libp11/libp11-0.4.12-r3.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
HOMEPAGE="https://github.com/opensc/libp11/wiki"
SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
@@ -20,11 +22,21 @@ BDEPEND="virtual/pkgconfig
doc? ( app-doc/doxygen )
test? ( dev-libs/opensc )"
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/libp11-0.4.12-openssl-3.1.patch
+ )
+ default
+ eautoreconf
+}
+
src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
+ local args=(
+ --enable-shared
+ $(use_enable static-libs static)
$(use_enable doc api-doc)
+ )
+ econf "${args[@]}"
}
src_install() {