summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-20 19:41:14 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-20 19:41:14 +0100
commit6b4415beac1d8b238889590a6d2fa2617d087ed9 (patch)
tree728e356a268ec37371b5dbc64f19be60af53ff1c /dev-libs/libxls/libxls-1.5.3.ebuild
parentapp-arch/zstd: Bump (diff)
downloadgentoo-6b4415beac1d8b238889590a6d2fa2617d087ed9.tar.gz
gentoo-6b4415beac1d8b238889590a6d2fa2617d087ed9.tar.bz2
gentoo-6b4415beac1d8b238889590a6d2fa2617d087ed9.zip
dev-libs/libxls: bump up to 1.5.3
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-libs/libxls/libxls-1.5.3.ebuild')
-rw-r--r--dev-libs/libxls/libxls-1.5.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libxls/libxls-1.5.3.ebuild b/dev-libs/libxls/libxls-1.5.3.ebuild
new file mode 100644
index 000000000000..6238aba02e32
--- /dev/null
+++ b/dev-libs/libxls/libxls-1.5.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A library which can read Excel (xls) files"
+HOMEPAGE="https://github.com/libxls/libxls"
+SRC_URI="https://github.com/libxls/libxls/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/1" # libxlsreader.so.1
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+BDEPEND="
+ app-arch/unzip
+ virtual/pkgconfig
+"
+
+RESTRICT=test # test driver is missing
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.0-asprintf.patch
+)
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+}