summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-12-22 11:32:11 +0100
committerFabian Groffen <grobian@gentoo.org>2016-12-22 11:32:11 +0100
commit9898c3fd681e2d7a5bcc038fec2758cff39a49aa (patch)
tree2b4ab102d0e0585c15b8af5f9ff40fb9152dae2b /dev-libs/libxslt
parentperl-core/Scalar-List-Utils: add Prefix keywords (diff)
downloadgentoo-9898c3fd681e2d7a5bcc038fec2758cff39a49aa.tar.gz
gentoo-9898c3fd681e2d7a5bcc038fec2758cff39a49aa.tar.bz2
gentoo-9898c3fd681e2d7a5bcc038fec2758cff39a49aa.zip
dev-libs/libxslt: add patch from upstream for Cygwin
Package-Manager: portage-2.2.28-prefix
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/files/libxslt-1.1.29-cygwin.patch29
-rw-r--r--dev-libs/libxslt/libxslt-1.1.29-r1.ebuild131
2 files changed, 160 insertions, 0 deletions
diff --git a/dev-libs/libxslt/files/libxslt-1.1.29-cygwin.patch b/dev-libs/libxslt/files/libxslt-1.1.29-cygwin.patch
new file mode 100644
index 000000000000..221da9a55da0
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt-1.1.29-cygwin.patch
@@ -0,0 +1,29 @@
+From 2fbf5b1f440534a46b7b440a487768620cfb039c Mon Sep 17 00:00:00 2001
+From: Michael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>
+Date: Wed, 13 Jul 2016 13:31:05 +0200
+Subject: Add WIN32_EXTRA_LDFLAGS to tests/plugins/Makefile.am
+
+Fixes a compilation problem with Cygwin.
+
+Fixes bug #766669:
+https://bugzilla.gnome.org/show_bug.cgi?id=766669
+---
+ tests/plugins/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/plugins/Makefile.am b/tests/plugins/Makefile.am
+index e0736ab..0f8c378 100644
+--- a/tests/plugins/Makefile.am
++++ b/tests/plugins/Makefile.am
+@@ -21,7 +21,7 @@ plugindir = $(abs_builddir)/.libs
+ xmlsoft_org_xslt_testplugin_la_CFLAGS = -DMODULE_COMPILE $(LIBXML_CFLAGS) $(LIBXSLT_CFLAGS)
+ xmlsoft_org_xslt_testplugin_la_SOURCES = testplugin.c
+ xmlsoft_org_xslt_testplugin_la_LIBADD = $(top_builddir)/libxslt/libxslt.la $(EXTRA_LIBS)
+-xmlsoft_org_xslt_testplugin_la_LDFLAGS = -module -avoid-version -rpath $(plugindir)
++xmlsoft_org_xslt_testplugin_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -module -avoid-version -rpath $(plugindir)
+
+ test-logall:
+ @echo '## Running plugin tests'
+--
+cgit v0.12
+
diff --git a/dev-libs/libxslt/libxslt-1.1.29-r1.ebuild b/dev-libs/libxslt/libxslt-1.1.29-r1.ebuild
new file mode 100644
index 000000000000..86ee4d8d7c71
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.29-r1.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit autotools eutils python-r1 toolchain-funcs multilib-minimal
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="crypt debug examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.9.1-r5:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}] )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2[python,${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/xslt-config
+)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libxslt/xsltconfig.h
+)
+
+src_prepare() {
+ default
+
+ DOCS=( AUTHORS ChangeLog FEATURES NEWS README TODO )
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=684621
+ eapply "${FILESDIR}"/${PN}.m4-${PN}-1.1.26.patch
+ # https://bugzilla.gnome.org/show_bug.cgi?id=766669
+ eapply "${FILESDIR}"/${PN}-1.1.29-cygwin.patch
+
+ # Simplify python setup
+ eapply "${FILESDIR}"/${PN}-1.1.28-simplify-python.patch
+ eapply "${FILESDIR}"/${PN}-1.1.28-disable-static-modules.patch
+
+ mv configure.{in,ac} || die
+
+ eautoreconf
+ # If eautoreconf'd with new autoconf, then epunt_cxx is not necessary
+ # and it is propably otherwise too if upstream generated with new
+ # autoconf
+# epunt_cxx
+ # But Prefix always needs elibtoolize if not eautoreconf'd.
+# elibtoolize
+}
+
+multilib_src_configure() {
+ libxslt_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-html-subdir=html \
+ $(use_with crypt crypto) \
+ $(use_with debug) \
+ $(use_with debug mem-debug) \
+ $(use_enable static-libs static) \
+ "$@"
+ }
+
+ libxslt_py_configure() {
+ mkdir -p "${BUILD_DIR}" || die # ensure python build dirs exist
+ run_in_build_dir libxslt_configure --with-python
+ }
+
+ libxslt_configure --without-python # build python bindings separately
+
+ if multilib_is_native_abi && use python; then
+ python_foreach_impl libxslt_py_configure
+ fi
+}
+
+multilib_src_compile() {
+ default
+ multilib_is_native_abi && use python && libxslt_foreach_py_emake all
+}
+
+multilib_src_test() {
+ default
+ multilib_is_native_abi && use python && libxslt_foreach_py_emake test
+}
+
+multilib_src_install() {
+ # "default" does not work here - docs are installed by multilib_src_install_all
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ libxslt_foreach_py_emake \
+ DESTDIR="${D}" \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR="${EPREFIX}"/usr/share/doc/${PF}/python/examples \
+ install
+ python_foreach_impl python_optimize
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use examples; then
+ rm -rf "${ED}"/usr/share/doc/${PF}/examples
+ rm -rf "${ED}"/usr/share/doc/${PF}/python/examples
+ fi
+
+ prune_libtool_files --modules
+}
+
+libxslt_foreach_py_emake() {
+ libxslt_py_emake() {
+ pushd "${BUILD_DIR}/python" > /dev/null || die
+ emake "$@"
+ popd > /dev/null
+ }
+ local native_builddir=${BUILD_DIR}
+ python_foreach_impl libxslt_py_emake top_builddir="${native_builddir}" "$@"
+}