summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-13 04:42:52 +0100
committerSam James <sam@gentoo.org>2023-04-13 04:44:44 +0100
commit4057dcbc657ddc5d1e3d603110ab2713cb590312 (patch)
treec936d96d3ad8d13d2dc39d104e3eccc16d846efa /dev-libs/openssl
parentapp-text/libpaper: add 2.0.12 (diff)
downloadgentoo-4057dcbc657ddc5d1e3d603110ab2713cb590312.tar.gz
gentoo-4057dcbc657ddc5d1e3d603110ab2713cb590312.tar.bz2
gentoo-4057dcbc657ddc5d1e3d603110ab2713cb590312.zip
dev-libs/openssl: filter LTO
The OpenSSL developers don't test with LTO right now, it leads to various warnings/errors (which may or may not be false positives), and it's not tested in CI: https://github.com/openssl/openssl/issues/18663. It's not considered supported at all. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/openssl-1.1.1t-r3.ebuild4
-rw-r--r--dev-libs/openssl/openssl-3.0.8-r3.ebuild4
-rw-r--r--dev-libs/openssl/openssl-3.1.0-r2.ebuild4
3 files changed, 12 insertions, 0 deletions
diff --git a/dev-libs/openssl/openssl-1.1.1t-r3.ebuild b/dev-libs/openssl/openssl-1.1.1t-r3.ebuild
index 1c29542e9287..f9c750974d5d 100644
--- a/dev-libs/openssl/openssl-1.1.1t-r3.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1t-r3.ebuild
@@ -140,6 +140,10 @@ src_configure() {
# Don't remove the no strict aliasing bits below!
filter-flags -fstrict-aliasing
append-flags -fno-strict-aliasing
+ # The OpenSSL developers don't test with LTO right now, it leads to various
+ # warnings/errors (which may or may not be false positives), it's considered
+ # unsupported, and it's not tested in CI: https://github.com/openssl/openssl/issues/18663.
+ filter-lto
append-cppflags -DOPENSSL_NO_BUF_FREELISTS
diff --git a/dev-libs/openssl/openssl-3.0.8-r3.ebuild b/dev-libs/openssl/openssl-3.0.8-r3.ebuild
index ad4ca4f3b019..47c1bd2d6e83 100644
--- a/dev-libs/openssl/openssl-3.0.8-r3.ebuild
+++ b/dev-libs/openssl/openssl-3.0.8-r3.ebuild
@@ -131,6 +131,10 @@ src_configure() {
# Don't remove the no strict aliasing bits below!
filter-flags -fstrict-aliasing
append-flags -fno-strict-aliasing
+ # The OpenSSL developers don't test with LTO right now, it leads to various
+ # warnings/errors (which may or may not be false positives), it's considered
+ # unsupported, and it's not tested in CI: https://github.com/openssl/openssl/issues/18663.
+ filter-lto
append-flags $(test-flags-CC -Wa,--noexecstack)
diff --git a/dev-libs/openssl/openssl-3.1.0-r2.ebuild b/dev-libs/openssl/openssl-3.1.0-r2.ebuild
index b5a3fe7adebf..82fbb55ebda8 100644
--- a/dev-libs/openssl/openssl-3.1.0-r2.ebuild
+++ b/dev-libs/openssl/openssl-3.1.0-r2.ebuild
@@ -134,6 +134,10 @@ src_configure() {
# Don't remove the no strict aliasing bits below!
filter-flags -fstrict-aliasing
append-flags -fno-strict-aliasing
+ # The OpenSSL developers don't test with LTO right now, it leads to various
+ # warnings/errors (which may or may not be false positives), it's considered
+ # unsupported, and it's not tested in CI: https://github.com/openssl/openssl/issues/18663.
+ filter-lto
append-flags $(test-flags-CC -Wa,--noexecstack)