summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-01-17 12:14:55 +0200
committerMart Raudsepp <leio@gentoo.org>2019-01-17 12:23:02 +0200
commitc8297e8429431c95e37fcaa44962240567bf56ea (patch)
tree376bfc81c1ed7067f309c0d757f695cb62b22dbe /dev-libs/totem-pl-parser
parentnet-misc/youtube-dl: Version 2019.01.17 (diff)
downloadgentoo-c8297e8429431c95e37fcaa44962240567bf56ea.tar.gz
gentoo-c8297e8429431c95e37fcaa44962240567bf56ea.tar.bz2
gentoo-c8297e8429431c95e37fcaa44962240567bf56ea.zip
dev-libs/totem-pl-parser: bump to 3.26.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/totem-pl-parser')
-rw-r--r--dev-libs/totem-pl-parser/Manifest1
-rw-r--r--dev-libs/totem-pl-parser/files/3.26.2-optional-introspection.patch35
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-3.26.2.ebuild68
3 files changed, 104 insertions, 0 deletions
diff --git a/dev-libs/totem-pl-parser/Manifest b/dev-libs/totem-pl-parser/Manifest
index bf321894776f..2f0258c541ca 100644
--- a/dev-libs/totem-pl-parser/Manifest
+++ b/dev-libs/totem-pl-parser/Manifest
@@ -1 +1,2 @@
DIST totem-pl-parser-3.10.8.tar.xz 1618992 BLAKE2B ab7dc3010afb9a2112f19991ee74c43436962a66fa233162b2d2c6743e5727762102f6f0bfed2a30750c0d4e3cf0fbfdb7fdab8568b0cb827e49d0f99a938c41 SHA512 1692fe6d183838bdfb9125ae2bf9fbf74762333a7ebb6becc755bfdbfb8d2ea1ae257f42aab7b7a1ab419aee2b35902176a731f26736a62015806d1423adae70
+DIST totem-pl-parser-3.26.2.tar.xz 1314032 BLAKE2B 1513223e7cdebf1b16587a8ef899dd0318d0474d3987a346525cb0f77966c87bf858510c6432f204e4ec758467da273c8644fa6976eb0da237b729f507763646 SHA512 b4d05f6c41942d243be411fb58aa557c0402eac56acc4fc213214a59d20df4354c17d5dec4064a5580f88e721411a16953e69e94c2ebe98e1aaf8b0729b8a83d
diff --git a/dev-libs/totem-pl-parser/files/3.26.2-optional-introspection.patch b/dev-libs/totem-pl-parser/files/3.26.2-optional-introspection.patch
new file mode 100644
index 000000000000..f258b20b73da
--- /dev/null
+++ b/dev-libs/totem-pl-parser/files/3.26.2-optional-introspection.patch
@@ -0,0 +1,35 @@
+From e097a4608cafac147546db658a4a37f8a23715ca Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Thu, 17 Jan 2019 01:16:40 +0200
+Subject: [PATCH] build: make introspection optional, not based on
+ cross-compiling
+
+This is how most other projects do it - cross-compiling that hits trouble
+can just disable it then.
+
+diff --git a/meson_options.txt b/meson_options.txt
+index 9c32a5f..58e9f8c 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -6,3 +6,5 @@ option('enable-libgcrypt', type: 'combo', choices : ['yes', 'no', 'auto'], value
+ description : 'Enable libgcrypt support.')
+ option('enable-gtk-doc', type: 'boolean', value: 'false',
+ description : 'Generate the API reference (depends on GTK-Doc)')
++option('enable-introspection', type: 'boolean', value: 'true',
++ description : 'Generate gobject-introspection bindings')
+diff --git a/plparse/meson.build b/plparse/meson.build
+index bdfde9d..ad4e344 100644
+--- a/plparse/meson.build
++++ b/plparse/meson.build
+@@ -121,7 +121,7 @@ if have_quvi
+ endif
+
+ # Introspection
+-if not meson.is_cross_build()
++if get_option('enable-introspection')
+ gnome.generate_gir(plparser_lib,
+ sources: plparser_public_headers + plparser_sources + [
+ totem_pl_parser_marshalers[1],
+--
+2.17.0
+
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-3.26.2.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-3.26.2.ebuild
new file mode 100644
index 000000000000..10d510358338
--- /dev/null
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-3.26.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org meson xdg
+
+DESCRIPTION="Playlist parsing library"
+HOMEPAGE="https://developer.gnome.org/totem-pl-parser/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="0/18"
+IUSE="archive crypt gtk-doc +introspection +quvi test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ quvi? ( >=media-libs/libquvi-0.9.1:0= )
+ archive? ( >=app-arch/libarchive-3 )
+ dev-libs/libxml2:2
+ crypt? ( dev-libs/libgcrypt:0= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ gnome-base/gvfs[http]
+ sys-apps/dbus )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-optional-introspection.patch
+)
+
+src_prepare() {
+ # Disable tests requiring network access, bug #346127
+ # 3rd test fails on upgrade, not once installed
+ # Leio: I consider network tests important for ensuring full functionality, thus trying with them again */
+ #sed -e 's:\(g_test_add_func.*/parser/resolution.*\):/*\1*/:' \
+ # -e 's:\(g_test_add_func.*/parser/parsing/itms_link.*\):/*\1*/:' \
+ # -e 's:\(g_test_add_func.*/parser/parsability.*\):/*\1*/:'\
+ # -i plparse/tests/parser.c || die "sed failed"
+
+ xdg_src_prepare
+}
+
+src_configure() {
+ # uninstalled-tests is abused to switch from loading live FS helper
+ # to in-build-tree helper, check on upgrades this is not having other
+ # consequences, bug #630242
+ local emesonargs=(
+ -Denable-quvi=$(usex quvi yes no)
+ -Denable-libarchive=$(usex archive yes no)
+ -Denable-libgcrypt=$(usex crypt yes no)
+ $(meson_use gtk-doc enable-gtk-doc)
+ $(meson_use introspection enable-introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # This is required as told by upstream in bgo#629542
+ GVFS_DISABLE_FUSE=1 dbus-run-session meson test -C "${BUILD_DIR}"
+}