summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-07 13:30:42 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-07 13:34:31 +0100
commit9ddf1017294aa912660bfbbf52c918bc260ea396 (patch)
treebdf7d22c66fd84bf345cced7dd2b32d2bdad216e /dev-libs/volume_key
parentkde-plasma/ksysguard: Set VIRTUALX_REQUIRED="test" (diff)
downloadgentoo-9ddf1017294aa912660bfbbf52c918bc260ea396.tar.gz
gentoo-9ddf1017294aa912660bfbbf52c918bc260ea396.tar.bz2
gentoo-9ddf1017294aa912660bfbbf52c918bc260ea396.zip
dev-libs/volume_key: Revbump fixing python3 lookup
Thanks-to: Mike Frysinger <vapier@gentoo.org> Closes: https://bugs.gentoo.org/764230 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/volume_key')
-rw-r--r--dev-libs/volume_key/files/volume_key-0.3.12-find_python3.patch27
-rw-r--r--dev-libs/volume_key/volume_key-0.3.12-r3.ebuild61
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-libs/volume_key/files/volume_key-0.3.12-find_python3.patch b/dev-libs/volume_key/files/volume_key-0.3.12-find_python3.patch
new file mode 100644
index 000000000000..3f7d6da69366
--- /dev/null
+++ b/dev-libs/volume_key/files/volume_key-0.3.12-find_python3.patch
@@ -0,0 +1,27 @@
+From d64fcc43ad740c91f4f1e1a6827663b2485f127a Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Thu, 7 Jan 2021 13:23:28 +0100
+Subject: [PATCH] configure.ac: Don't look for old python3 versions
+
+Gentoo-bug: https://bugs.gentoo.org/764230
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4eda5eb..2dce575 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -101,7 +101,7 @@ if test "x$use_python3" = xno; then
+ else
+ AC_MSG_RESULT([testing])
+ # Try to find Python 3 interpreter:
+- AC_PATH_PROGS([PYTHON3], [python3.6 python3.5 python3 python], [no])
++ AC_PATH_PROGS([PYTHON3], [python3], [no])
+ if test "x$PYTHON3" != xno; then
+ AC_MSG_CHECKING([whether $PYTHON3 version is >= 3.5])
+ python3_found=old
+--
+2.30.0
+
diff --git a/dev-libs/volume_key/volume_key-0.3.12-r3.ebuild b/dev-libs/volume_key/volume_key-0.3.12-r3.ebuild
new file mode 100644
index 000000000000..1ff596ac27b9
--- /dev/null
+++ b/dev-libs/volume_key/volume_key-0.3.12-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Library for manipulating and storing storage volume encryption keys"
+HOMEPAGE="https://pagure.io/volume_key"
+SRC_URI="http://releases.pagure.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-crypt/gpgme
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ sys-apps/util-linux
+ sys-fs/cryptsetup:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ test? ( dev-libs/nss[utils] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-support_higher_LUKS_versions.patch"
+ "${FILESDIR}/${PN}-0.3.12-find_python3.patch" #764230
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf #764230
+}
+
+src_configure() {
+ # --without-python disables python2
+ econf --without-python --with-python3
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ python_optimize
+}