summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-09-26 17:01:51 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-10-21 15:38:31 +0300
commit2876b60db80b6b4545d885e0d9e92628f42a0a05 (patch)
tree6d3d9f5532008087d89c4be958cdace8ea905ea8 /dev-libs
parentmedia-sound/ncmpcpp: add 0.10_p20240912 (diff)
downloadgentoo-2876b60db80b6b4545d885e0d9e92628f42a0a05.tar.gz
gentoo-2876b60db80b6b4545d885e0d9e92628f42a0a05.tar.bz2
gentoo-2876b60db80b6b4545d885e0d9e92628f42a0a05.zip
dev-libs/modsecurity: add 3.0.13
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/modsecurity/Manifest1
-rw-r--r--dev-libs/modsecurity/metadata.xml2
-rw-r--r--dev-libs/modsecurity/modsecurity-3.0.13.ebuild71
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-libs/modsecurity/Manifest b/dev-libs/modsecurity/Manifest
index e0a65901d957..8e80b2815b93 100644
--- a/dev-libs/modsecurity/Manifest
+++ b/dev-libs/modsecurity/Manifest
@@ -1,3 +1,4 @@
DIST modsecurity-slibtool.patch 6915 BLAKE2B 9d067a4285cf56cbe9c824601724ee9caaf43e1bce653e51c6f66165a96e034125d93c4c998ee27df4d753c5e176b21d1c524dd72710428aaff1e528bddf48dc SHA512 a4c413f376c19bd028f2824f837cfdd5dffa51fcfeb1bcd911ca36a2876372d47f5e225b22cf9416d45cfc65e9e476501917a2b5c6d785f650c918f81164a8be
DIST modsecurity-v3.0.10.tar.gz 3341295 BLAKE2B 9ae4d52ccc77eb7f6a50fb37b07d0c0022e7d4c93bc4c04e7c6cdfabc7b6f6a19a3f0ec1f0151eb1bbd98d9c55de774048bc7636f67e735169b8c628d71fc0fd SHA512 2f51c9bfd2e91d93ddb8c48671dca08f91682745ff6bab6b8153376207d77c40f9afdcab7fa04d2fe925a19343bbfc57e52f0b45b3a50b30de4c1949f5b77ed9
DIST modsecurity-v3.0.12.tar.gz 3504045 BLAKE2B 6ee7f56384452bef090b26b567cc229f690fafbff4cb704b87bc241f1ec827eafc5de8b236936c4e7d58ed2e5c3ed30472ff24b8d18744d3f1bdc346c41c5940 SHA512 34c87bd12e76d102e95b626113c4b0c9e971be196932e76f0703c9c4416925baf99ccf5f46b88e317dc284f12e00ec099d6842574cb785086fa43950487919b3
+DIST modsecurity-v3.0.13.tar.gz 9677566 BLAKE2B 303bae03241192987d7376c978181bbfd85816c0dd4daade86fee42721e38b99e681c36b1ecbd685e21d7a0bf83bdd5000787df115189194212782d330c67312 SHA512 1e683f7be2454126dcbd689d990259114a12fa56dd82b5283809282b6a12001550b7527e8bde7a0864ea19600094c06be09497ad7be7977fa419efcf9359885a
diff --git a/dev-libs/modsecurity/metadata.xml b/dev-libs/modsecurity/metadata.xml
index dac598b1ea55..83e68cd7e13f 100644
--- a/dev-libs/modsecurity/metadata.xml
+++ b/dev-libs/modsecurity/metadata.xml
@@ -30,6 +30,6 @@
</flag>
</use>
<upstream>
- <remote-id type="github">SpiderLabs/ModSecurity</remote-id>
+ <remote-id type="github">owasp-modsecurity/ModSecurity</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-libs/modsecurity/modsecurity-3.0.13.ebuild b/dev-libs/modsecurity/modsecurity-3.0.13.ebuild
new file mode 100644
index 000000000000..1457f7f24787
--- /dev/null
+++ b/dev-libs/modsecurity/modsecurity-3.0.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Application firewall and intrusion detection"
+HOMEPAGE="https://github.com/owasp-modsecurity/ModSecurity"
+SRC_URI="
+ https://github.com/owasp-modsecurity/ModSecurity/releases/download/v${PV}/${MY_P}.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc fuzzyhash geoip geoip2 json lmdb lua pcre2"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RDEPEND="dev-libs/libpcre:=
+ dev-libs/libxml2
+ net-misc/curl
+ fuzzyhash? ( app-crypt/ssdeep )
+ geoip? ( dev-libs/geoip )
+ geoip2? ( dev-libs/libmaxminddb )
+ json? ( dev-libs/yajl )
+ lmdb? ( dev-db/lmdb )
+ lua? ( ${LUA_DEPS} )
+ pcre2? ( dev-libs/libpcre2:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/doxygen[dot] )"
+
+DOCS=( AUTHORS CHANGES README.md modsecurity.conf-recommended unicode.mapping )
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with fuzzyhash ssdeep)
+ $(use_with geoip )
+ $(use_with geoip2 maxmind)
+ $(use_with json yajl)
+ $(use_with lmdb)
+ $(use_with lua)
+ $(use_with pcre2)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd doc && doxygen doxygen.cfg || die
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/html
+ find "${ED}" -name '*.la' -delete || die
+}