summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 09:16:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-12 09:17:49 +0200
commit96b6e72566ca3e28f78abdcdc246eb5a5686a82e (patch)
tree2142d1af3000e2ee65a6bf0e89a6b83e96567eff /dev-libs
parentx11-libs/libX11-1.6.6: alpha stable, bug 664184 (diff)
downloadgentoo-96b6e72566ca3e28f78abdcdc246eb5a5686a82e.tar.gz
gentoo-96b6e72566ca3e28f78abdcdc246eb5a5686a82e.tar.bz2
gentoo-96b6e72566ca3e28f78abdcdc246eb5a5686a82e.zip
dev-libs/appstream: 0.12.2 version bump
Closes: https://bugs.gentoo.org/646252 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/appstream/Manifest1
-rw-r--r--dev-libs/appstream/appstream-0.12.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/appstream/Manifest b/dev-libs/appstream/Manifest
index c05f76d7c8cf..ee36d2e416fb 100644
--- a/dev-libs/appstream/Manifest
+++ b/dev-libs/appstream/Manifest
@@ -1,2 +1,3 @@
+DIST AppStream-0.12.2.tar.xz 1938868 BLAKE2B 968853e9d5f87ca2c1f894a6ffe5439f7fce611459243cd96d3859a15e225243585a1a43e90d8eca8271b91e1237d94eb4615b5c3c0543d9a37646b5fbd7d2fe SHA512 d5c95309d4fddb961f4a5b9ac460840e34d4bae0e256bd0be09ceeab0d45a3ac5254c9e9c183a1e6cb3983ce0a9d6d0e519908f612a5b135ed578ec26556e53d
DIST appstream-0.10.6.tar.gz 1821879 BLAKE2B 49e0476ef41c37d2e9bb12a7c046fcbb2cd8fcb1f521321dce4cda15e504a966cf59a1cbf56fc7359a82f677c54906ba041ad37eeb7f639ad69691e8d2ccd24c SHA512 9f8b4ddc39d580c62b166df0d9a2c5e4caac1b433d25a4e9118b7c73ceea5c7b1ff78f02d682a68cdfeb8da29e806a4838cfc11637fca2982f436af333605256
DIST appstream-0.11.5.tar.gz 1856204 BLAKE2B 9f1e423e71e40b569cae0fb259bf5a0203a0abcba64f877c951c941f1dfdbc8005509ca46040586b8937cc168ad9315978dd2a3763592de1686c9648eac6c928 SHA512 308f65df2d03f09a5fdfe1d5b61ed37ddfd73a6f7cd861f685463c45ba17a2a937ba34216b4d5f533cb5f9f56c65ff9b261e03d07aaab74bec3f89e5bfb57d7b
diff --git a/dev-libs/appstream/appstream-0.12.2.ebuild b/dev-libs/appstream/appstream-0.12.2.ebuild
new file mode 100644
index 000000000000..dffda1b04b3f
--- /dev/null
+++ b/dev-libs/appstream/appstream-0.12.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson xdg-utils
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ximion/${PN}"
+else
+ MY_PN="AppStream"
+ SRC_URI="https://www.freedesktop.org/software/appstream/releases/${MY_PN}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
+HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# check as_api_level
+SLOT="0/4"
+IUSE="apt qt5 test"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=dev-libs/gobject-introspection-1.56
+ dev-libs/libxml2:2
+ dev-libs/libyaml
+ dev-libs/snowball-stemmer
+ qt5? ( dev-qt/qtcore:5 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ dev-util/itstool
+ >=dev-util/meson-0.42.0
+ sys-devel/gettext
+ test? (
+ qt5? ( dev-qt/qttest:5 )
+ )
+"
+
+src_prepare() {
+ default
+ sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local emesonargs=(
+ -Dapidocs=false
+ -Ddocs=false
+ -Dmaintainer=false
+ -Dstemming=true
+ -Dvapi=false
+ -Dapt-support=$(usex apt true false)
+ -Dqt=$(usex qt5 true false)
+ )
+
+ meson_src_configure
+}