summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-24 00:08:03 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-24 00:10:05 +0300
commitdecf8ddd1637249d1c3a121a3bd60c03e64ed55a (patch)
tree5399da83b5b15206e68870f2a32b4c9774c48bf5 /dev-libs
parentgames-puzzle/atomix: bump to 3.34.0 (diff)
downloadgentoo-decf8ddd1637249d1c3a121a3bd60c03e64ed55a.tar.gz
gentoo-decf8ddd1637249d1c3a121a3bd60c03e64ed55a.tar.bz2
gentoo-decf8ddd1637249d1c3a121a3bd60c03e64ed55a.zip
dev-libs/gdl: bump to 3.34.0
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gdl/Manifest1
-rw-r--r--dev-libs/gdl/gdl-3.34.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/gdl/Manifest b/dev-libs/gdl/Manifest
index 1db740c28757..f478a81f98f3 100644
--- a/dev-libs/gdl/Manifest
+++ b/dev-libs/gdl/Manifest
@@ -1 +1,2 @@
DIST gdl-3.28.0.tar.xz 541252 BLAKE2B 7254a9e15e9e79229c85b12c02ff5307bf99569428b13629ac8b3a5e79383f14a248d6e74f139e44145cd1a2825a2d10859c922a07a22fe1243edfafdb01514b SHA512 d6a697b8cd098abfcb560d8b6c8a326b05f6f22211a3bc92ea458d643170abc514acd4105e372fb61777d2a5dd09709d7e3d6d3ad75215fffdf2809b3df3c471
+DIST gdl-3.34.0.tar.xz 531368 BLAKE2B 5e32c330ab2fda0b9f06de0fd9d7e3f3118b0af36a73f4f0280f069b49002a4d00e5cbfd373d65b0ea7a15bb5b577f8babbdf7ee71ed7db773d2ad65008a452e SHA512 8c43f330556dae67e4f64e92c3ba5c2e9351d3040d6002bda89f20f9494fc93030abe80072f0cf86280f98e290805154e9ca12aaa7013f0a341d8ea94323d3b0
diff --git a/dev-libs/gdl/gdl-3.34.0.ebuild b/dev-libs/gdl/gdl-3.34.0.ebuild
new file mode 100644
index 000000000000..827c89eccd02
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.34.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://git.gnome.org/browse/gdl"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-gtk-doc
+}