summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:14:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:31 +0100
commit023117f0fdfbf5bd536508314f06d9a814667354 (patch)
tree5831c415b70c8df74ea741801b214019fd88e7b2 /dev-lua/busted-htest
parentdev-lua/busted: drop 2.0.0-r101 (diff)
downloadgentoo-023117f0fdfbf5bd536508314f06d9a814667354.tar.gz
gentoo-023117f0fdfbf5bd536508314f06d9a814667354.tar.bz2
gentoo-023117f0fdfbf5bd536508314f06d9a814667354.zip
dev-lua/busted-htest: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/busted-htest')
-rw-r--r--dev-lua/busted-htest/busted-htest-1.0.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lua/busted-htest/busted-htest-1.0.0-r1.ebuild b/dev-lua/busted-htest/busted-htest-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..69cd12b55e7b
--- /dev/null
+++ b/dev-lua/busted-htest/busted-htest-1.0.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua
+
+DESCRIPTION="Pretty output handler for Busted"
+HOMEPAGE="https://github.com/hishamhm/busted-htest"
+SRC_URI="https://github.com/hishamhm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lua/busted[${LUA_USEDEP}]
+ ${LUA_DEPS}
+"
+
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins src/busted/outputHandlers/htest.lua
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}