summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-26 09:52:06 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-03-26 09:52:06 +0200
commit8fa26385ba95b10d68b868bc8158349c3ffada4d (patch)
treef37bcaafceff47052b4eb6ec009cba0ae66e1e5c /dev-ml/camlp4/camlp4-4.12-r2.ebuild
parentdev-ml/findlib: fix collision (diff)
downloadgentoo-8fa26385ba95b10d68b868bc8158349c3ffada4d.tar.gz
gentoo-8fa26385ba95b10d68b868bc8158349c3ffada4d.tar.bz2
gentoo-8fa26385ba95b10d68b868bc8158349c3ffada4d.zip
dev-ml/camlp4: META file belong to its package
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/camlp4/camlp4-4.12-r2.ebuild')
-rw-r--r--dev-ml/camlp4/camlp4-4.12-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/camlp4/camlp4-4.12-r2.ebuild b/dev-ml/camlp4/camlp4-4.12-r2.ebuild
new file mode 100644
index 000000000000..64641f012733
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.12-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/camlp4/camlp4"
+SRC_URI="https://github.com/camlp4/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild[ocamlopt?]
+ dev-ml/findlib:="
+
+QA_FLAGS_IGNORED='.*'
+
+S=${WORKDIR}/${P/_p/-}
+PATCHES=( "${FILESDIR}/reload.patch" )
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}