summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-02 15:30:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-02 20:29:06 +0100
commit3f421c70bf47c0daa31316723426d5571d681434 (patch)
tree2fbfcb99622fa8010d8424a47ecc4eed9432c690 /dev-ml/camlpdf/camlpdf-2.1.1.ebuild
parentdev-ml/core: bump to 113.24.02 (diff)
downloadgentoo-3f421c70bf47c0daa31316723426d5571d681434.tar.gz
gentoo-3f421c70bf47c0daa31316723426d5571d681434.tar.bz2
gentoo-3f421c70bf47c0daa31316723426d5571d681434.zip
dev-ml/camlpdf: fix build with ocaml 4.03
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/camlpdf/camlpdf-2.1.1.ebuild')
-rw-r--r--dev-ml/camlpdf/camlpdf-2.1.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ml/camlpdf/camlpdf-2.1.1.ebuild b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
index 83226661473c..8ba49799866b 100644
--- a/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
+++ b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit findlib
+inherit findlib eutils
DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
@@ -19,6 +19,10 @@ IUSE="doc examples"
RDEPEND="dev-lang/ocaml:="
DEPEND="${RDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/ocaml43.patch"
+}
+
src_compile() {
# parallel make bugs
emake -j1