summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-02 22:51:41 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-02 22:52:16 +0200
commitf2a6fa0463f6ad112cd01fc20d3a068aacb11d49 (patch)
tree166087d39edc9b7c3ac7399df4e2c436627ecdf8 /dev-ml/core/core-0.14.0-r6.ebuild
parentapp-laptop/tuxedo-control-center-bin: add 2.1.8 (diff)
downloadgentoo-f2a6fa0463f6ad112cd01fc20d3a068aacb11d49.tar.gz
gentoo-f2a6fa0463f6ad112cd01fc20d3a068aacb11d49.tar.bz2
gentoo-f2a6fa0463f6ad112cd01fc20d3a068aacb11d49.zip
dev-ml/core: add dev-ml/jane-street-headers deps
Closes: https://bugs.gentoo.org/922714 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/core/core-0.14.0-r6.ebuild')
-rw-r--r--dev-ml/core/core-0.14.0-r6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.14.0-r6.ebuild b/dev-ml/core/core-0.14.0-r6.ebuild
new file mode 100644
index 000000000000..8de3801b0c69
--- /dev/null
+++ b/dev-ml/core/core-0.14.0-r6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
+IUSE="+ocamlopt"
+
+# TODO: Wants quickcheck_deprecated?
+RESTRICT="test"
+
+RDEPEND="
+ <dev-lang/ocaml-4.12
+ <dev-ml/base-0.15:=
+ <dev-ml/core_kernel-0.15:=
+ <dev-ml/jst-config-0.15:=
+ <dev-ml/ppx_jane-0.15:=
+ <dev-ml/sexplib-0.15:=
+ dev-ml/spawn:=
+ dev-ml/stdio:0/0.14.0
+ dev-ml/timezone:0/0.14.0
+ dev-ml/jane-street-headers:0/0.14.0
+"
+DEPEND="${RDEPEND}"