summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-10 19:30:35 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-10 19:31:49 +0200
commit88b7dc066c69138c3217e70862d4404b6023ef8f (patch)
tree92524c6ec176549f71eecf5cf337d302fee52e85 /dev-ml/ocaml-compiler-libs
parentdev-python/pytest-forked: Fix variable order (diff)
downloadgentoo-88b7dc066c69138c3217e70862d4404b6023ef8f.tar.gz
gentoo-88b7dc066c69138c3217e70862d4404b6023ef8f.tar.bz2
gentoo-88b7dc066c69138c3217e70862d4404b6023ef8f.zip
dev-ml/ocaml-compiler-libs: add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-compiler-libs')
-rw-r--r--dev-ml/ocaml-compiler-libs/Manifest1
-rw-r--r--dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.17.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ocaml-compiler-libs/Manifest b/dev-ml/ocaml-compiler-libs/Manifest
index fefe68183192..2b03304ae31f 100644
--- a/dev-ml/ocaml-compiler-libs/Manifest
+++ b/dev-ml/ocaml-compiler-libs/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-compiler-libs-0.12.3.tar.gz 4982 BLAKE2B 83432cbb2707964f025b294a84cdcce77137156e409d85ce8615dd6e9a26ad085cd5de178ebeb7520cd95b19a15b3cfbf7ef9567d165b55e07850a231b68371c SHA512 748ae11fe4cedb12d153ef2e712a9899f6a7ab4a35ddb7c95c0ae25af979c3edf274046745dddb2253fc06be41d5b0029f11a5a823a17d1ee680ffb29c4bdc89
DIST ocaml-compiler-libs-0.12.4.tar.gz 5435 BLAKE2B 2c7b3f79315945d094dd4102da748dda55265bdd36753606ec03eef6a39eb385b84e7bfd0f43a04583271bf7c53b15481e9dcbb48c362d472bb3f740ec48853a SHA512 cf08e8d4bf25fff26a16a05036f08247176f4845d9d9ada85944c3fa89b6df9a5092d7a1025415a3b2ce00dd45b544cc82247648cf3952be2304e5d9ebab121d
+DIST ocaml-compiler-libs-0.17.0.tar.gz 5006 BLAKE2B c5f5f3e257167fad012135a76a82d6c2609a7ba6956f2380c8d19fc5f8360a2110b1cfcec9eecbe779c5c155d3b593791a084f588c6c105246adf30e2d1a1d63 SHA512 c5cd418b0eb74e00c3f63235754bbdb3a3328ac743d6ae885424d8c50b4edaa7068572e689cb3456d222793283927f2984a1ff840b1bc3817f810b5314faf897
diff --git a/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.17.0.ebuild b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.17.0.ebuild
new file mode 100644
index 000000000000..f273051c7a1f
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.17.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Repackage the OCaml compiler libs so they do not expose everything at toplevel"
+HOMEPAGE="https://github.com/janestreet/ocaml-compiler-libs"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ >=dev-ml/dune-3.11
+ >=dev-lang/ocaml-5.2.0
+"