summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-19 21:37:42 +0000
committerSam James <sam@gentoo.org>2020-10-20 01:37:16 +0000
commit855fd9dbcfd594da29eb7bcf9e27bd6ccc32df94 (patch)
treefd206dd9f8986e468936d4682111c25763d97201 /dev-ml/ocaml-ssl
parentdev-ml/ocurl: cleanup old (diff)
downloadgentoo-855fd9dbcfd594da29eb7bcf9e27bd6ccc32df94.tar.gz
gentoo-855fd9dbcfd594da29eb7bcf9e27bd6ccc32df94.tar.bz2
gentoo-855fd9dbcfd594da29eb7bcf9e27bd6ccc32df94.zip
dev-ml/ocaml-ssl: bump to 0.5.9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ssl')
-rw-r--r--dev-ml/ocaml-ssl/Manifest1
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/Manifest b/dev-ml/ocaml-ssl/Manifest
index 948a1bbf1e3c..63710733cda7 100644
--- a/dev-ml/ocaml-ssl/Manifest
+++ b/dev-ml/ocaml-ssl/Manifest
@@ -1,3 +1,4 @@
+DIST 0.5.9.tar.gz 32721 BLAKE2B c6b1ec659fddf384005f2cb045c0b0c059daaa93bd782904354e12e1ce63432c04c9bdc823dbfd0cd903ce872c91f0a750975cc69a56c9384ef6d09ed46c22cd SHA512 6826e5a6ab9f51013e8d097900f443d091e085e3d2d232a315a0e3a90ca334c9b9779d20dcae267f9ed961bc4a08fcb80372e669389c59a22d5c7706d37fcd5f
DIST ocaml-ssl-0.5.3.tar.gz 125431 BLAKE2B e95b6757f27fcac16dda1087880bb49ad854108755719210aeeeebd0e14cfee9b6244986f21ddbf86a970ea4b4f9eb2bb8e0a5a888dafe2a7262f004194a26ba SHA512 c0dc38ab21c8adc104a42ec89b8a58de976205887a23a407f1ffee1181d526ddb8aa91877508f8a974c6df8583d6d8611558a995680e313fc78ad0cac184cf52
DIST ocaml-ssl-0.5.4.tar.gz 125833 BLAKE2B 983f1c1301c2dd313d91c180e8654baef39b1de2f3f3688ba40d920d5c16fd1626b1cf9dc8a6f172045ab4b8cd75b4048b3956ff9835a57c534bacdb1ddce32d SHA512 4a221bd8f5c11871040f6f117d3152ec2fca28f0311dfcc2ac39d2ed55c66203e12ad3242368273d8f17f1ca87c1b5d929ab7fec8ec7a03a564c7c25ade3d289
DIST ocaml-ssl-0.5.5.tar.gz 125778 BLAKE2B 7be315a349df7948adc69b64cce65d29ce0d7cc8b492d4f3948a3a72e64951c323b8f5d3fa48825fe0119ff5d8c94a03d95e36ec695768aae0751f5f3df4397b SHA512 4e3a78426bc2a5cec0ade43b1b324366b4bf0d93be6e7bc73f1152499f2ab0642d3edcf4484a519ea6ec0b44bc76c0c984b9bba59121f93bc065b1c0355969c0
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild
new file mode 100644
index 000000000000..0bb8af882f5a
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="ssl"
+inherit dune
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="https://github.com/savonet/ocaml-ssl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+
+IUSE="doc +ocamlopt"
+
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+
+src_install() {
+ dune_src_install
+
+ dodoc CHANGES README.md
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/html/*
+ fi
+}