summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-21 21:45:17 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-21 21:45:17 +0100
commit6706fd03a5c3c40795773e07d3306860f00e75bd (patch)
tree4ac6c8fdfd1dd4f369294ad6a86861b772c8e8ab /dev-ml
parentdev-ml/0install: new package, add 2.18 (diff)
downloadgentoo-6706fd03a5c3c40795773e07d3306860f00e75bd.tar.gz
gentoo-6706fd03a5c3c40795773e07d3306860f00e75bd.tar.bz2
gentoo-6706fd03a5c3c40795773e07d3306860f00e75bd.zip
dev-ml/opam-0install-cudf: new package, add 0.5.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-0install-cudf/Manifest1
-rw-r--r--dev-ml/opam-0install-cudf/metadata.xml23
-rw-r--r--dev-ml/opam-0install-cudf/opam-0install-cudf-0.5.0.ebuild20
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/opam-0install-cudf/Manifest b/dev-ml/opam-0install-cudf/Manifest
new file mode 100644
index 000000000000..07d60554cdb0
--- /dev/null
+++ b/dev-ml/opam-0install-cudf/Manifest
@@ -0,0 +1 @@
+DIST opam-0install-cudf-0.5.0.tar.gz 9327 BLAKE2B 705e0bcdd8311e5c330f37e5b05ccb02fa73e42603d0c574480c54101fb746a5d5b61176811dff9eaf09bac370f064dfb8a9ada8f4912586a79e7fccefd122ad SHA512 83c0372168d612ef80548ab7fb021a92cdc39e13a77d87c5af5fd21eb515389b624d09c24d500e9ac33b3fc10d17c9869f160f8771f9c8f545b0453b9a0fd4df
diff --git a/dev-ml/opam-0install-cudf/metadata.xml b/dev-ml/opam-0install-cudf/metadata.xml
new file mode 100644
index 000000000000..923f467c195e
--- /dev/null
+++ b/dev-ml/opam-0install-cudf/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">
+ Opam's default solver is designed to maintain a set of packages over
+ time, minimising disruption when installing new programs and finding a
+ compromise solution across all packages.
+ In many situations (e.g. CI, local roots or duniverse builds) this is
+ not necessary, and we can get a solution much faster by using a
+ different algorithm.
+ This package provides a generic solver library which uses 0install's
+ solver library. The library uses the CUDF library in order to interface
+ with opam as it is the format common used to talk to all the supported
+ solvers.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ocaml-opam/opam-0install-cudf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-0install-cudf/opam-0install-cudf-0.5.0.ebuild b/dev-ml/opam-0install-cudf/opam-0install-cudf-0.5.0.ebuild
new file mode 100644
index 000000000000..9db05d077373
--- /dev/null
+++ b/dev-ml/opam-0install-cudf/opam-0install-cudf-0.5.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Opam solver using 0install backend using the CUDF interface"
+HOMEPAGE="https://github.com/ocaml-opam/opam-0install-cudf"
+SRC_URI="https://github.com/ocaml-opam/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+ocamlopt"
+
+src_configure() {
+ :
+}