summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-29 05:22:29 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-29 05:23:08 +1200
commit84acb344b2734b5b0a359fd4601c9bf3c0b6569a (patch)
treed2a933e2c48f26c8defafefe98fd8cce355f6d52 /dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild
parentnet-wireless/rtl-sdr: add zerocopy use flag (diff)
downloadgentoo-84acb344b2734b5b0a359fd4601c9bf3c0b6569a.tar.gz
gentoo-84acb344b2734b5b0a359fd4601c9bf3c0b6569a.tar.bz2
gentoo-84acb344b2734b5b0a359fd4601c9bf3c0b6569a.zip
dev-perl/Archive-Zip: Bump to version 1.680.0
- EAPI7 - Add app-arch/unzip for tests - Dropped keywords: - amd64-linux m68k-mint ppc-aix sparc-solaris sparc64-solaris x64-solaris x86-solaris ppc-macos x64-macos x86-macos - Due to app-arch/unzip Upstream: - Fix for members using bzip compression - Expect NetBSD unzip not minding empty zips - Add diag for Solaris test failures - Fix skip line for Windows - Skip tests that assume /tmp on windows - Improved Zip64 support - Set 'compressedSize' after writing central directory header - Add $noFormatError parameter for _readSignature - Add error handling for failing object conversion after calling A:Z:Member::_become - A:Z:{Archive,Member}::contents now consistently returns a ($contents,$status) in list context, and just $contents in scalar context - A:Z:Member::extractToFileHandle now supports file names when extracting symbolic links - Remove need for Test::MockModule - examples/zipcheck.pl now skips symbolic links - Tests now less picky about OS-specific unzip -t quirks - Various other test suite overhauls and improvements Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild')
-rw-r--r--dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild b/dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild
new file mode 100644
index 000000000000..284448806814
--- /dev/null
+++ b/dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PHRED
+DIST_VERSION=1.68
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="A wrapper that lets you read Zip archive members as if they were files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Compress-Raw-Zlib-2.17.0
+ virtual/perl-Encode
+ virtual/perl-File-Path
+ >=virtual/perl-File-Spec-0.800.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Time-Local
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ app-arch/unzip
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"