summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-14 08:06:18 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-14 08:06:32 +1200
commit00cdf1ba210ebefb9b8f81eb78d649239aebeb50 (patch)
treee4566aa0ead4ae4380fb5ec59f4e9e3e894bfb9b /dev-perl/DBIx-Class-InflateColumn-IP
parentprofiles/package.mask: unmask net-irc/irker post-bump (diff)
downloadgentoo-00cdf1ba210ebefb9b8f81eb78d649239aebeb50.tar.gz
gentoo-00cdf1ba210ebefb9b8f81eb78d649239aebeb50.tar.bz2
gentoo-00cdf1ba210ebefb9b8f81eb78d649239aebeb50.zip
dev-perl/DBIx-Class-InflateColumn-IP: -r bump for EAPI7 + fixes
- EAPI7 - Move 'sed' hacks to a patch - Unconditionally prune bad test files Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DBIx-Class-InflateColumn-IP')
-rw-r--r--dev-perl/DBIx-Class-InflateColumn-IP/DBIx-Class-InflateColumn-IP-0.20.30-r2.ebuild31
-rw-r--r--dev-perl/DBIx-Class-InflateColumn-IP/files/DBIx-Class-InflateColumn-IP-0.02003-no-dot-inc.patch24
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/DBIx-Class-InflateColumn-IP/DBIx-Class-InflateColumn-IP-0.20.30-r2.ebuild b/dev-perl/DBIx-Class-InflateColumn-IP/DBIx-Class-InflateColumn-IP-0.20.30-r2.ebuild
new file mode 100644
index 000000000000..be97246c9fb8
--- /dev/null
+++ b/dev-perl/DBIx-Class-InflateColumn-IP/DBIx-Class-InflateColumn-IP-0.20.30-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ILMARI
+DIST_VERSION=0.02003
+inherit perl-module
+
+DESCRIPTION="Auto-create NetAddr::IP objects from columns"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/NetAddr-IP
+ >=dev-perl/DBIx-Class-0.81.70
+"
+BDEPEND="${RDEPEND}
+ test? ( dev-perl/DBD-SQLite )
+"
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod-t.
+ t/style-notabs.t
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-0.02003-no-dot-inc.patch"
+)
diff --git a/dev-perl/DBIx-Class-InflateColumn-IP/files/DBIx-Class-InflateColumn-IP-0.02003-no-dot-inc.patch b/dev-perl/DBIx-Class-InflateColumn-IP/files/DBIx-Class-InflateColumn-IP-0.02003-no-dot-inc.patch
new file mode 100644
index 000000000000..11d943c35512
--- /dev/null
+++ b/dev-perl/DBIx-Class-InflateColumn-IP/files/DBIx-Class-InflateColumn-IP-0.02003-no-dot-inc.patch
@@ -0,0 +1,24 @@
+From 1346fbc9264cd17ec0082042d91ea5d6c2966a03 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 14 Jul 2020 07:59:34 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index df23607..6aa04ff 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,7 @@
+ use strict;
+ use warnings;
+ use 5.008001;
++use lib '.';
+ use inc::Module::Install 1.05;
+
+ name 'DBIx-Class-InflateColumn-IP';
+--
+2.27.0
+