summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-09 04:29:13 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-09 08:07:00 +1300
commit47e7af94a99fa66611cd32f7a24ae5b34c8e00b9 (patch)
tree214d487b50d2fd3a965fcc41501eaa6ed0efc86c /dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild
parentdev-perl/Event-RPC: Bump to version 1.80.0 (diff)
downloadgentoo-47e7af94a99fa66611cd32f7a24ae5b34c8e00b9.tar.gz
gentoo-47e7af94a99fa66611cd32f7a24ae5b34c8e00b9.tar.bz2
gentoo-47e7af94a99fa66611cd32f7a24ae5b34c8e00b9.zip
dev-perl/Exception-Class: Bump to version 1.410.0
- EAPI6 - USE="examples" Upstream: - Packaging fixes Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild')
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild
new file mode 100644
index 000000000000..20726baefe85
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.410.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.41
+DIST_EXAMPLES=("bench/*")
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"