summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-01 18:20:35 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-01 21:01:29 +1300
commit61041966119c616bd7a782ca41b602c1ef2b2e51 (patch)
tree51e4d3b8114846b404c071c38f70488c88cbe7a4 /dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild
parentdev-perl/Mail-Message: Bump to version 3.2.0 (diff)
downloadgentoo-61041966119c616bd7a782ca41b602c1ef2b2e51.tar.gz
gentoo-61041966119c616bd7a782ca41b602c1ef2b2e51.tar.bz2
gentoo-61041966119c616bd7a782ca41b602c1ef2b2e51.zip
dev-perl/Mail-Sendmail: Bump to version 0.800.0
- EAPI6 - Add basic compile tests - Make it possible to execute network tests Upstream: - Simplify license to Perl - Add experimental SMTP Auth - Fix bug where refused RCPT TO does global abort - send EHLO and parse response (Auth TODO) - Better handle multi-line responses - Better error messages - Normalize line endings in headers - Keep Sender header if used - Remove space after RCPT TO and MAIL FROM header Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild')
-rw-r--r--dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild b/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild
new file mode 100644
index 000000000000..d9ca6ac0c360
--- /dev/null
+++ b/dev-perl/Mail-Sendmail/Mail-Sendmail-0.800.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NEILB
+DIST_VERSION=0.80
+inherit perl-module
+
+DESCRIPTION="Simple platform independent mailer"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ virtual/perl-Exporter
+ virtual/perl-MIME-Base64
+ virtual/perl-Socket
+ virtual/perl-Time-Local
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ local MODULES=(
+ "Mail::Sendmail ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ if has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ perl-module_src_test
+ else
+ ewarn "Network tests disabled without DIST_TEST_OVERRIDE=~network"
+ fi
+}