summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Module-Install
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Module-Install')
-rw-r--r--dev-perl/Module-Install/Manifest3
-rw-r--r--dev-perl/Module-Install/Module-Install-1.140.0.ebuild44
-rw-r--r--dev-perl/Module-Install/Module-Install-1.160.0.ebuild46
-rw-r--r--dev-perl/Module-Install/Module-Install-1.60.0-r1.ebuild34
-rw-r--r--dev-perl/Module-Install/metadata.xml44
5 files changed, 171 insertions, 0 deletions
diff --git a/dev-perl/Module-Install/Manifest b/dev-perl/Module-Install/Manifest
new file mode 100644
index 000000000000..9dd1165273fe
--- /dev/null
+++ b/dev-perl/Module-Install/Manifest
@@ -0,0 +1,3 @@
+DIST Module-Install-1.06.tar.gz 135467 SHA256 de9ec8395b3b497d6d9629859b54086643c3911dff80cc7e0e22b380cb194519 SHA512 0bc90ee5e53923af7d1bf0359587762c4a79cc35608ff38e9c4a3bb0e3fb122a596a29c3cc6e91c75e7c7670d65683ce9cb2510ca39d889676fb88c038e444fa WHIRLPOOL 022e7668c8a3190f23720d7b9f0bbe8c4a6e4f79a498d7edefe3e55f796c819f2ca3695ede05bfa61b7c2986cb8dbcc710c80e67048f6616cd7102ddba2ac1c6
+DIST Module-Install-1.14.tar.gz 128795 SHA256 3f02f0a33603aff2f5cf06d15f74d1a9be65e844ada99e1a9c2102330ffa0d49 SHA512 2a2c8686b8a5b8aba6314d8434a75dca75e692d1e251bad9287fd9555bf62c5bdab52e88a64d6723f4b9bfe6b57958496869d5fbb35ca45adba4c75fd9d5cf9f WHIRLPOOL 99fb42ab9cf4211c6d41931015402f49a71d7c9d0117c5247fd4cdc7955c5e003ec64b4c37d2208f4179bc65600476a7e4a78572c2a48d50665ca69198958844
+DIST Module-Install-1.16.tar.gz 113004 SHA256 afac1264255f4d822d44f84df1aa9affad207f9ae805e803d93c845fa120025e SHA512 479a3b1a3e489c100bcb25c9f90445abcc90d194238804849b7d3ca1fa171a625b99f8390ce8967e96b10e854d843d117c70e566f12309b3ccdf32113f006422 WHIRLPOOL 909765d0acbb095ec085f8aee346cbaa515d96d08f2fdff66989d41ec59c1e38164df2b51639437b3bf71601270cbdf96e010cb2d5f52471bf5d416054402ddf
diff --git a/dev-perl/Module-Install/Module-Install-1.140.0.ebuild b/dev-perl/Module-Install/Module-Install-1.140.0.ebuild
new file mode 100644
index 000000000000..15a033d62a5a
--- /dev/null
+++ b/dev-perl/Module-Install/Module-Install-1.140.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BINGOS
+MODULE_VERSION=1.14
+inherit perl-module
+
+DESCRIPTION="Standalone, extensible Perl module installer"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Devel-PPPort-3.160.0
+ >=virtual/perl-ExtUtils-Install-1.520.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-2.190.0
+ >=dev-perl/File-Remove-1.420.0
+ >=virtual/perl-File-Spec-3.280.0
+ >=dev-perl/Module-Build-0.290.0
+ >=virtual/perl-Module-CoreList-2.170.0
+ >=dev-perl/Module-ScanDeps-1.90.0
+ >=virtual/perl-Parse-CPAN-Meta-1.441.300
+ >=dev-perl/YAML-Tiny-1.380.0
+ >=dev-perl/Archive-Zip-1.370.0
+ >=dev-perl/File-HomeDir-1
+ >=dev-perl/JSON-2.900.0
+ >=dev-perl/libwww-perl-6
+ >=dev-perl/PAR-Dist-0.290.0
+"
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ >=virtual/perl-Test-Harness-3.130.0
+ >=virtual/perl-Test-Simple-0.860.0
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Module-Install/Module-Install-1.160.0.ebuild b/dev-perl/Module-Install/Module-Install-1.160.0.ebuild
new file mode 100644
index 000000000000..eb094d495488
--- /dev/null
+++ b/dev-perl/Module-Install/Module-Install-1.160.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=1.16
+inherit perl-module
+
+DESCRIPTION="Standalone, extensible Perl module installer"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Devel-PPPort-3.160.0
+ >=virtual/perl-ExtUtils-Install-1.520.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-2.190.0
+ >=dev-perl/File-Remove-1.420.0
+ >=virtual/perl-File-Spec-3.280.0
+ >=dev-perl/Module-Build-0.290.0
+ >=virtual/perl-Module-CoreList-2.170.0
+ >=dev-perl/Module-ScanDeps-1.90.0
+ >=virtual/perl-Parse-CPAN-Meta-1.441.300
+ >=dev-perl/YAML-Tiny-1.380.0
+ >=dev-perl/Archive-Zip-1.370.0
+ >=dev-perl/File-HomeDir-1
+ >=dev-perl/JSON-2.900.0
+ >=dev-perl/libwww-perl-6
+ >=dev-perl/PAR-Dist-0.290.0
+"
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ virtual/perl-autodie
+ >=dev-perl/YAML-Tiny-1.330.0
+ test? (
+ >=virtual/perl-Test-Harness-3.130.0
+ >=virtual/perl-Test-Simple-0.860.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Module-Install/Module-Install-1.60.0-r1.ebuild b/dev-perl/Module-Install/Module-Install-1.60.0-r1.ebuild
new file mode 100644
index 000000000000..15ae93217c0f
--- /dev/null
+++ b/dev-perl/Module-Install/Module-Install-1.60.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=1.06
+inherit perl-module
+
+DESCRIPTION="Standalone, extensible Perl module installer"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ia64 ~ppc ~ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=virtual/perl-File-Spec-3.28
+ >=virtual/perl-Archive-Tar-1.44
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-2.19
+ >=dev-perl/Module-Build-0.33
+ >=virtual/perl-Module-CoreList-2.17
+ >=virtual/perl-Parse-CPAN-Meta-1.39
+ >=dev-perl/libwww-perl-5.812
+ >=dev-perl/File-Remove-1.42
+ >=dev-perl/JSON-2.14
+ >=dev-perl/Module-ScanDeps-0.89
+ >=dev-perl/PAR-Dist-0.29
+ >=dev-perl/YAML-Tiny-1.38"
+DEPEND="${RDEPEND}
+ test? ( >=virtual/perl-Test-Harness-3.13
+ >=virtual/perl-Test-Simple-0.86 )"
+
+SRC_TEST=do
diff --git a/dev-perl/Module-Install/metadata.xml b/dev-perl/Module-Install/metadata.xml
new file mode 100644
index 000000000000..1d68b8dea73a
--- /dev/null
+++ b/dev-perl/Module-Install/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Module-Install</remote-id>
+ <remote-id type="cpan-module">Module::AutoInstall</remote-id>
+ <remote-id type="cpan-module">Module::Install</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::Bundle</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::Compiler</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::Find</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::Include</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::Makefile</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::Manifest</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::Metadata</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::ScanDeps</remote-id>
+ <remote-id type="cpan-module">Module::Install::Admin::WriteAll</remote-id>
+ <remote-id type="cpan-module">Module::Install::AutoInstall</remote-id>
+ <remote-id type="cpan-module">Module::Install::Base</remote-id>
+ <remote-id type="cpan-module">Module::Install::Base::FakeAdmin</remote-id>
+ <remote-id type="cpan-module">Module::Install::Bundle</remote-id>
+ <remote-id type="cpan-module">Module::Install::Can</remote-id>
+ <remote-id type="cpan-module">Module::Install::Compiler</remote-id>
+ <remote-id type="cpan-module">Module::Install::DSL</remote-id>
+ <remote-id type="cpan-module">Module::Install::Deprecated</remote-id>
+ <remote-id type="cpan-module">Module::Install::External</remote-id>
+ <remote-id type="cpan-module">Module::Install::Fetch</remote-id>
+ <remote-id type="cpan-module">Module::Install::Include</remote-id>
+ <remote-id type="cpan-module">Module::Install::Inline</remote-id>
+ <remote-id type="cpan-module">Module::Install::MakeMaker</remote-id>
+ <remote-id type="cpan-module">Module::Install::Makefile</remote-id>
+ <remote-id type="cpan-module">Module::Install::Metadata</remote-id>
+ <remote-id type="cpan-module">Module::Install::PAR</remote-id>
+ <remote-id type="cpan-module">Module::Install::Run</remote-id>
+ <remote-id type="cpan-module">Module::Install::Scripts</remote-id>
+ <remote-id type="cpan-module">Module::Install::Share</remote-id>
+ <remote-id type="cpan-module">Module::Install::Win32</remote-id>
+ <remote-id type="cpan-module">Module::Install::With</remote-id>
+ <remote-id type="cpan-module">Module::Install::WriteAll</remote-id>
+ <remote-id type="cpan-module">inc::Module::Install</remote-id>
+ <remote-id type="cpan-module">inc::Module::Install::DSL</remote-id>
+ </upstream>
+</pkgmetadata>