summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Greter <marcel.greter@ocbnet.ch>2018-01-13 04:57:10 +0100
committerKent Fredric <kentnl@gentoo.org>2018-01-24 17:40:43 +1300
commitf77afa38d6f043304e1713d6a121b59539c0a4fe (patch)
tree67ff18f7b4ceef9dba7ef751e593a310e51cc10f /dev-perl/Quota
parentsys-apps/busybox: turn off some features uClibc omits #567598 (diff)
downloadgentoo-f77afa38d6f043304e1713d6a121b59539c0a4fe.tar.gz
gentoo-f77afa38d6f043304e1713d6a121b59539c0a4fe.tar.bz2
gentoo-f77afa38d6f043304e1713d6a121b59539c0a4fe.zip
dev-perl/Quota: Fix linkage against libtirpc bug #644420
- add dependency to libtirpc - add minimal test case Closes: https://bugs.gentoo.org/644420 Closes: https://github.com/gentoo/gentoo/pull/6845
Diffstat (limited to 'dev-perl/Quota')
-rw-r--r--dev-perl/Quota/Quota-1.7.2.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/dev-perl/Quota/Quota-1.7.2.ebuild b/dev-perl/Quota/Quota-1.7.2.ebuild
index 7e107a67f8fd..74a17df08e44 100644
--- a/dev-perl/Quota/Quota-1.7.2.ebuild
+++ b/dev-perl/Quota/Quota-1.7.2.ebuild
@@ -14,6 +14,7 @@ IUSE=""
RDEPEND="
sys-fs/quota[rpc]
+ net-libs/libtirpc
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
@@ -24,8 +25,20 @@ DIST_TEST=skip
src_prepare() {
default
- export mymake="OPTIMIZE=$($(tc-getPKG_CONFIG) --cflags libtirpc)"
+ export mymake="INC=$($(tc-getPKG_CONFIG) --cflags libtirpc) OTHERLDFLAGS=$($(tc-getPKG_CONFIG) --libs libtirpc)"
# disable AFS completely for now, need somebody who can really test it
sed -i -e 's|-d "/afs"|0|' Makefile.PL || die "sed failed"
}
+
+src_test() {
+ ebegin "Compile testing Quota ${PV}"
+ perl -Mblib="${S}" -M"Quota ${PV} ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Quota ${PV}"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}