summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/phpcov
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/phpcov')
-rw-r--r--dev-php/phpcov/Manifest1
-rw-r--r--dev-php/phpcov/metadata.xml8
-rw-r--r--dev-php/phpcov/phpcov-1.1.0.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/phpcov/Manifest b/dev-php/phpcov/Manifest
new file mode 100644
index 000000000000..f88768708aed
--- /dev/null
+++ b/dev-php/phpcov/Manifest
@@ -0,0 +1 @@
+DIST phpcov-1.1.0.phar 3552394 SHA256 f2294bdbd305486b3c2b85d6a6f0906fcd4ecf125867988607670438db34446f SHA512 690a66afacca15a9851c0d13b7ee449a928a9862dd7e0b88ef4f0da6a9ad9663d087c2225d822f9fbb0afd08a881f44d7bd64c069d29c598293eb423aa6b30cb WHIRLPOOL 8816d9d66fcdc94909649ec8cbcdd883827107432ff58b4ea964f20d648044d3edb66102acc13f0b68e1a55d21fd6d97a36dd18a16cf8d2c173a5dd00cae5c8c
diff --git a/dev-php/phpcov/metadata.xml b/dev-php/phpcov/metadata.xml
new file mode 100644
index 000000000000..6321a19367e0
--- /dev/null
+++ b/dev-php/phpcov/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <upstream>
+ <remote-id type="github">sebastianbergmann/phpcov</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phpcov/phpcov-1.1.0.ebuild b/dev-php/phpcov/phpcov-1.1.0.ebuild
new file mode 100644
index 000000000000..6aeed8fcec66
--- /dev/null
+++ b/dev-php/phpcov/phpcov-1.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="CLI frontend for PHP_CodeCoverage"
+HOMEPAGE="https://github.com/sebastianbergmann/phpcov"
+SRC_URI="https://phar.phpunit.de/${P}.phar"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[phar]
+ dev-php/xdebug"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ insopts -m755
+ newins "${DISTDIR}"/${P}.phar "${PN}.phar"
+ dosym /usr/share/php/${PN}/${PN}.phar /usr/bin/${PN}
+}