summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-08 13:56:55 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-08 14:49:47 +0200
commit73e64e5b0c3a0b0d668bd5a358404bbbd08dec8a (patch)
tree59f7278a7ebd6e3cd5c5ba5ce440adda6f24a081 /dev-php
parentnet-firewall/shorewall: bump to v5.2.6 (diff)
downloadgentoo-73e64e5b0c3a0b0d668bd5a358404bbbd08dec8a.tar.gz
gentoo-73e64e5b0c3a0b0d668bd5a358404bbbd08dec8a.tar.bz2
gentoo-73e64e5b0c3a0b0d668bd5a358404bbbd08dec8a.zip
dev-php/pecl-mongodb: bump to v1.7.5
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-mongodb/Manifest1
-rw-r--r--dev-php/pecl-mongodb/pecl-mongodb-1.7.5.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-php/pecl-mongodb/Manifest b/dev-php/pecl-mongodb/Manifest
index c2868de23949..abacdcf89d98 100644
--- a/dev-php/pecl-mongodb/Manifest
+++ b/dev-php/pecl-mongodb/Manifest
@@ -2,3 +2,4 @@ DIST mongodb-1.5.3.tgz 1059580 BLAKE2B 23bd5f6b0f218cf55bd5713a770f3990d5c149292
DIST mongodb-1.5.5.tgz 1060017 BLAKE2B 475ca0f6a1cbd5270c9bde0f195d6092ef25441e0cee0a45ed378a868bd1ad27c7a77c4f4702b6f82004433805563cdaa728cbc11bb5beff83b982122cad339b SHA512 1eefc8f8e359a979082dc7808e89ff5418cd2dc73d4250638e33dc32cce40ef42502e9dbbb07303381e0062b84818568034f4e4cda8c8bf905513d00bf008392
DIST mongodb-1.6.0.tgz 1096156 BLAKE2B 16c3b1d07d31d29a214aba320347f8e40cfc4f0dae8b0713b02cd0e3ff98fd54b09217472f333722228efdfcae755bbdbfe58da7db89d4dda2893ba7b3b0e8bb SHA512 e75dc607bf41bb71a0fce3b73785ef4203af97a3e8b21bf70a80c2216e9530463a6aaca55b013a4fa2f3c4eb72405a25209935ea1a238475f990763af54aa641
DIST mongodb-1.7.4.tgz 1223416 BLAKE2B 9db40284eb2b70e242f26c1661923c5f33de8ab1e33a7e816863b61fcbc49040204ca556b1f384cab958f9dc2cf4e49e97840b78bd520a4e374b83210a964e5d SHA512 6805ce1d0958e24e1edf3bc9698bc1f4a9d31c26250624fd35aebf7a7d310af30050e1974cd9571f989303fce4c5522e793a8cb41388397df66e8f5fe0a648f2
+DIST mongodb-1.7.5.tgz 1223892 BLAKE2B c30a217d1170c31be00259f4bb58cfea186947fa0bf1653de32e228a8eb8d3fb25b52d7a5a9e16f6b311418d977f7aa00bf96ca9d7e9ac9a8fa7b6fe05eace8f SHA512 f0565adc42659d4070e42122d02a8306f29d6d70fe0b5e9a92144df346a8c672aafdf36613435b9dc8d50db5e98c2359fdf97408c45439d4d447257b85e93122
diff --git a/dev-php/pecl-mongodb/pecl-mongodb-1.7.5.ebuild b/dev-php/pecl-mongodb/pecl-mongodb-1.7.5.ebuild
new file mode 100644
index 000000000000..ddc120fee581
--- /dev/null
+++ b/dev-php/pecl-mongodb/pecl-mongodb-1.7.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PHP_EXT_NAME="mongodb"
+USE_PHP="php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="MongoDB database driver for PHP"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl sasl test"
+
+PHP_DEPEND="
+ php_targets_php7-2? ( dev-lang/php:7.2[json,ssl,zlib] )
+ php_targets_php7-3? ( dev-lang/php:7.3[json,ssl,zlib] )
+ php_targets_php7-4? ( dev-lang/php:7.4[json,ssl,zlib] )"
+COMMON_DEPEND="${PHP_DEPEND}
+ >=dev-libs/libbson-1.16.2
+ >=dev-libs/mongo-c-driver-1.16.2[sasl?,ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-db/mongodb )"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="${PHP_DEPEND}
+ virtual/pkgconfig"
+
+# No tests on x86 because tests require dev-db/mongodb which don't support
+# x86 anymore (bug #645994)
+RESTRICT="x86? ( test )
+ !test? ( test )"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-mongodb
+ --with-libbson
+ --with-libmongoc
+ --with-mongodb-sasl=$(usex sasl)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local PORT=27017
+ mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
+ --dbpath="${T}" --logpath="${T}/mongod.log" || die
+ php-ext-pecl-r3_src_test
+ kill $(<"${T}/mongod.lock")
+}