summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-09-14 09:13:41 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-09-14 09:17:04 -0400
commit898b60b9cf30aa263de97a7c31ff2b548dfa790c (patch)
treee3801232a5e335d7181c072b96d0637a1c816a08 /dev-php
parentsys-devel/clang-runtime: Remove obsolete warning (diff)
downloadgentoo-898b60b9cf30aa263de97a7c31ff2b548dfa790c.tar.gz
gentoo-898b60b9cf30aa263de97a7c31ff2b548dfa790c.tar.bz2
gentoo-898b60b9cf30aa263de97a7c31ff2b548dfa790c.zip
dev-php/smarty: add 4.2.1 to fix a javascript injection.
This new version also drops the old HTML manual that was downloaded with USE=doc. The modern smarty docs are included in the git repo, but not presently in the release tarballs... Bug: https://bugs.gentoo.org/870100 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/Manifest1
-rw-r--r--dev-php/smarty/smarty-4.2.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index a362a1bc8fe3..020bd6bb7a7a 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,2 +1,3 @@
DIST manual-en.3.1.14.zip 408414 BLAKE2B 03d4e7a386eb3bd5b19e5c555ec34b86812838a5b5fac8ec0ab9701fba89a5867714da57d950f68224a89bbe2267c18d638ee850681860de309c74bbfb3d0a0b SHA512 d384e3856b45ed3f992f3732a5465120abe9fb947cdf13ff67a9c4264f72987d24885ee61cd7309b728e64cdfe4f34c3e7f757096d35de56d962f3b78def9e58
DIST smarty-4.1.1.tar.gz 235624 BLAKE2B c624812ebebb1a8d09a5d80e2826b4e0e90310f6f53f903c9e962542b41b5c150ede1031f66c290e4dc2bb336eb532fd3305a3d97c7e43768d45f57df6815448 SHA512 93e601959651a00bdf9be9c9ddcfea6b189f70270ec8ab4764d2759c0c4de07c74a79cf4e42ee97d16c246130d6f1da5c8601fa60e5194906fe3b416934d1ef5
+DIST smarty-4.2.1.tar.gz 236881 BLAKE2B 4014178cfc4411a9ded3120d0e3e977af0190bc03f6ed21bbd2c484ca8fb4e5aa79fe9c606ee13be87db94c17a00d7d0399cb04fe09c4b439b95bc7b9331d675 SHA512 0d55ab1d329aaa0853a1c40b5b0207d3ddc8b0c25d863a217b3c4ac8bb0a796bb60eda2919b5dda569565b03b8dd44dff67b55d8fafc005164f2848bb481d131
diff --git a/dev-php/smarty/smarty-4.2.1.ebuild b/dev-php/smarty/smarty-4.2.1.ebuild
new file mode 100644
index 000000000000..d19caaedccde
--- /dev/null
+++ b/dev-php/smarty/smarty-4.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="https://www.smarty.net/ https://github.com/smarty-php/smarty/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ # The smarty docs and examples aren't part of the tarball,
+ # https://github.com/smarty-php/smarty/issues/799
+ local DOCS=( CHANGELOG.md README.md SECURITY.md )
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}