summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-03 12:44:02 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-03 12:44:02 +0300
commitc47ac53e6c4efbe05baf75ff7a3ad68485aed535 (patch)
treed8590b228ac5c10058bd1120cad4060748e1f339 /dev-php
parentnet-wireless/hostapd: remove libressl support (diff)
downloadgentoo-c47ac53e6c4efbe05baf75ff7a3ad68485aed535.tar.gz
gentoo-c47ac53e6c4efbe05baf75ff7a3ad68485aed535.tar.bz2
gentoo-c47ac53e6c4efbe05baf75ff7a3ad68485aed535.zip
dev-php/swoole: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/swoole/swoole-4.2.13.ebuild6
-rw-r--r--dev-php/swoole/swoole-4.4.12.ebuild7
-rw-r--r--dev-php/swoole/swoole-4.4.14.ebuild7
-rw-r--r--dev-php/swoole/swoole-4.4.15.ebuild7
-rw-r--r--dev-php/swoole/swoole-4.4.16.ebuild7
-rw-r--r--dev-php/swoole/swoole-4.4.19.ebuild7
-rw-r--r--dev-php/swoole/swoole-4.5.9.ebuild7
7 files changed, 21 insertions, 27 deletions
diff --git a/dev-php/swoole/swoole-4.2.13.ebuild b/dev-php/swoole/swoole-4.2.13.ebuild
index 04aa2e40c373..facb4470ae85 100644
--- a/dev-php/swoole/swoole-4.2.13.ebuild
+++ b/dev-php/swoole/swoole-4.2.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -27,7 +27,7 @@ DEPEND="
dev-libs/boost:0=
dev-libs/libpcre
http2? ( net-libs/nghttp2:0= )
- ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:0= ) )
+ ssl? ( dev-libs/openssl:0= )
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
php_targets_php7-3? ( dev-lang/php:7.3[cli,sockets?] )
@@ -40,7 +40,7 @@ DEPEND="
RDEPEND="${DEPEND}"
-IUSE="debug http2 libressl mysql sockets ssl"
+IUSE="debug http2 mysql sockets ssl"
src_configure() {
# PostgreSQL disabled due to Gentoo's slot system
diff --git a/dev-php/swoole/swoole-4.4.12.ebuild b/dev-php/swoole/swoole-4.4.12.ebuild
index 7df45e4948c0..dd3020308708 100644
--- a/dev-php/swoole/swoole-4.4.12.ebuild
+++ b/dev-php/swoole/swoole-4.4.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
@@ -47,7 +46,7 @@ DEPEND="
RDEPEND="${DEPEND}"
-IUSE="debug http2 libressl mysql sockets ssl"
+IUSE="debug http2 mysql sockets ssl"
src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
diff --git a/dev-php/swoole/swoole-4.4.14.ebuild b/dev-php/swoole/swoole-4.4.14.ebuild
index 146edf124e9f..dd3020308708 100644
--- a/dev-php/swoole/swoole-4.4.14.ebuild
+++ b/dev-php/swoole/swoole-4.4.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
@@ -47,7 +46,7 @@ DEPEND="
RDEPEND="${DEPEND}"
-IUSE="debug http2 libressl mysql sockets ssl"
+IUSE="debug http2 mysql sockets ssl"
src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
diff --git a/dev-php/swoole/swoole-4.4.15.ebuild b/dev-php/swoole/swoole-4.4.15.ebuild
index 146edf124e9f..dd3020308708 100644
--- a/dev-php/swoole/swoole-4.4.15.ebuild
+++ b/dev-php/swoole/swoole-4.4.15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
@@ -47,7 +46,7 @@ DEPEND="
RDEPEND="${DEPEND}"
-IUSE="debug http2 libressl mysql sockets ssl"
+IUSE="debug http2 mysql sockets ssl"
src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
diff --git a/dev-php/swoole/swoole-4.4.16.ebuild b/dev-php/swoole/swoole-4.4.16.ebuild
index 146edf124e9f..dd3020308708 100644
--- a/dev-php/swoole/swoole-4.4.16.ebuild
+++ b/dev-php/swoole/swoole-4.4.16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
@@ -47,7 +46,7 @@ DEPEND="
RDEPEND="${DEPEND}"
-IUSE="debug http2 libressl mysql sockets ssl"
+IUSE="debug http2 mysql sockets ssl"
src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
diff --git a/dev-php/swoole/swoole-4.4.19.ebuild b/dev-php/swoole/swoole-4.4.19.ebuild
index 146edf124e9f..dd3020308708 100644
--- a/dev-php/swoole/swoole-4.4.19.ebuild
+++ b/dev-php/swoole/swoole-4.4.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -30,8 +30,7 @@ DEPEND="
sys-libs/zlib:0=
http2? ( net-libs/nghttp2:0= )
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
)
php_targets_php7-1? ( dev-lang/php:7.1[cli,sockets?] )
php_targets_php7-2? ( dev-lang/php:7.2[cli,sockets?] )
@@ -47,7 +46,7 @@ DEPEND="
RDEPEND="${DEPEND}"
-IUSE="debug http2 libressl mysql sockets ssl"
+IUSE="debug http2 mysql sockets ssl"
src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory
diff --git a/dev-php/swoole/swoole-4.5.9.ebuild b/dev-php/swoole/swoole-4.5.9.ebuild
index 721b5a84f00b..48523b05538a 100644
--- a/dev-php/swoole/swoole-4.5.9.ebuild
+++ b/dev-php/swoole/swoole-4.5.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -28,8 +28,7 @@ DEPEND="
dev-libs/libpcre
sys-libs/zlib:0=
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
)
mysql? (
php_targets_php7-2? ( dev-lang/php:7.2[mysql,mysqli(+)] )
@@ -41,7 +40,7 @@ DEPEND="
RDEPEND="${DEPEND}"
-IUSE="debug http2 libressl mysql sockets ssl"
+IUSE="debug http2 mysql sockets ssl"
src_configure() {
# JEMalloc not included as it refuses to find a ${EROOT}/usr/includes/jemalloc subdirectory