summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-14 16:00:42 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-14 16:13:04 +0100
commit2ccd30ff47a5913af651e9d87be8b8485453a666 (patch)
treef06cea5ff2e6dde1e0fb5e82abe7fb1815900de0 /dev-python/Frozen-Flask
parentdev-util/hip: add extend-isa-compatibility-check patch (diff)
downloadgentoo-2ccd30ff47a5913af651e9d87be8b8485453a666.tar.gz
gentoo-2ccd30ff47a5913af651e9d87be8b8485453a666.tar.bz2
gentoo-2ccd30ff47a5913af651e9d87be8b8485453a666.zip
dev-python/Frozen-Flask: Fix compat with hatchling-1.20.0
Closes: https://bugs.gentoo.org/919842 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Frozen-Flask')
-rw-r--r--dev-python/Frozen-Flask/Frozen-Flask-1.0.1.ebuild4
-rw-r--r--dev-python/Frozen-Flask/files/Frozen-Flask-1.0.1-hatchling.patch34
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/Frozen-Flask/Frozen-Flask-1.0.1.ebuild b/dev-python/Frozen-Flask/Frozen-Flask-1.0.1.ebuild
index 800b9180f5ab..06ceefb68ef6 100644
--- a/dev-python/Frozen-Flask/Frozen-Flask-1.0.1.ebuild
+++ b/dev-python/Frozen-Flask/Frozen-Flask-1.0.1.ebuild
@@ -25,3 +25,7 @@ RDEPEND="
distutils_enable_sphinx docs \
dev-python/flask-sphinx-themes
distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${P}-hatchling.patch"
+)
diff --git a/dev-python/Frozen-Flask/files/Frozen-Flask-1.0.1-hatchling.patch b/dev-python/Frozen-Flask/files/Frozen-Flask-1.0.1-hatchling.patch
new file mode 100644
index 000000000000..f2c433b0b84f
--- /dev/null
+++ b/dev-python/Frozen-Flask/files/Frozen-Flask-1.0.1-hatchling.patch
@@ -0,0 +1,34 @@
+From 8b2bd9f75deef895e3c9f076419b22a7b1fa63aa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 14 Dec 2023 15:54:39 +0100
+Subject: [PATCH] Fix finding packages witch hatchling >= 1.19.0
+
+Explicitly specify the package name to install, in order to fix
+compatibility with `hatchling >= 1.19.0`. Starting with this version
+(though Frozen-Flask is affected since 1.20.0, due to a bug
+in hatchling), it is necessary to explicitly select packages if they
+do not
+
+As of hatchling >= 1.19.0, it is necessary to explicitly specify
+`packages` to use if they do not fit the default heuristics (i.e. are
+disjoint from the project name).
+
+Since the package is now specified explicitly, the `exclude` rules are
+no longer necessary.
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 2fdfefc..fcf6c1d 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -52,7 +52,7 @@ path = 'flask_frozen/__init__.py'
+ exclude = ['.*']
+
+ [tool.hatch.build.targets.wheel]
+-exclude = ['docs', 'tests']
++packages = ['flask_frozen']
+
+ [tool.hatch.envs.doc]
+ features = ['doc']