summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 09:48:15 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 09:56:49 +0200
commit33e13f53e6d558632ff5ccdf80f4669bf40f66a5 (patch)
tree6eb2910ee423ba84150ecf35609147de84ad7356 /dev-python/PyContracts
parentdev-python/coverage: Kill tests in <5 to unblock deps (diff)
downloadgentoo-33e13f53e6d558632ff5ccdf80f4669bf40f66a5.tar.gz
gentoo-33e13f53e6d558632ff5ccdf80f4669bf40f66a5.tar.bz2
gentoo-33e13f53e6d558632ff5ccdf80f4669bf40f66a5.zip
dev-python/PyContracts: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/PyContracts')
-rw-r--r--dev-python/PyContracts/PyContracts-1.8.14-r1.ebuild (renamed from dev-python/PyContracts/PyContracts-1.8.14.ebuild)8
1 files changed, 1 insertions, 7 deletions
diff --git a/dev-python/PyContracts/PyContracts-1.8.14.ebuild b/dev-python/PyContracts/PyContracts-1.8.14-r1.ebuild
index 52346ca9fc52..38b49352c989 100644
--- a/dev-python/PyContracts/PyContracts-1.8.14.ebuild
+++ b/dev-python/PyContracts/PyContracts-1.8.14-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -24,9 +24,3 @@ RDEPEND="
"
distutils_enable_tests nose
-
-python_test() {
- nosetests -v \
- $(python_is_python3 || echo "--ignore-files=test_py3k_annotations.py") \
- || die
-}