summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-17 19:39:53 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-17 19:44:58 +0100
commit777b60271cc0c16cad96dc5f8d1b2d88c6893469 (patch)
tree6dd967ad064816cb25dc42b3e25aaff2aa720506 /dev-python/aiorpcx
parentdev-ada/gpr: add 24.0.0 (diff)
downloadgentoo-777b60271cc0c16cad96dc5f8d1b2d88c6893469.tar.gz
gentoo-777b60271cc0c16cad96dc5f8d1b2d88c6893469.tar.bz2
gentoo-777b60271cc0c16cad96dc5f8d1b2d88c6893469.zip
dev-python/aiorpcx: Bump to 0.23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiorpcx')
-rw-r--r--dev-python/aiorpcx/Manifest1
-rw-r--r--dev-python/aiorpcx/aiorpcx-0.23.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aiorpcx/Manifest b/dev-python/aiorpcx/Manifest
index f5071b6e7dae..dffa34dd1f32 100644
--- a/dev-python/aiorpcx/Manifest
+++ b/dev-python/aiorpcx/Manifest
@@ -1 +1,2 @@
DIST aiorpcX-0.22.1.gh.tar.gz 75206 BLAKE2B 92c481388198fec94faa10482ad4195fe6dce5ae4aa445ce2812e1e81e084c629712b87a3c157aa33ae42335c1a96bdcafa5e389802740fcae8eb9e4aaf43dd2 SHA512 3484da36ce6042d8d4c6b168fd2326c0fc77a825691b95631e54510697708a27ea07e9a808445d504056432adf04f04cb0bc28d4b7194c55c1995096bb938b4d
+DIST aiorpcX-0.23.1.gh.tar.gz 70759 BLAKE2B e61aeee430670962491d165fe6841653b035b96cd07a70e6be0a0f4f5d5891859398826e4a964cd119ae7e42f2e02808363ab44b6b8f28054d86539c5067cf7b SHA512 e92f68da0783bcf66926047ab2af12b5971f4bab0a028a639e53440c9cfc39ba54ddbdd1c2a20a6dacf73dac583305f692851c0d911cd68d6aabdbe131b1a8e1
diff --git a/dev-python/aiorpcx/aiorpcx-0.23.1.ebuild b/dev-python/aiorpcx/aiorpcx-0.23.1.ebuild
new file mode 100644
index 000000000000..ee083de7de0a
--- /dev/null
+++ b/dev-python/aiorpcx/aiorpcx-0.23.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=aiorpcX-${PV}
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="
+ https://github.com/kyuupichan/aiorpcX/
+ https://pypi.org/project/aiorpcX/
+"
+SRC_URI="
+ https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+)