summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-11 07:15:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-11 07:17:42 +0200
commit40bc49784d705340b516b16f4de837df25737947 (patch)
tree4df35ff469f67f19550cfac7eb4bcd21208dc4e3 /dev-python/aiostream
parentdev-python/accessible-pygments: Bump to 0.0.5 (diff)
downloadgentoo-40bc49784d705340b516b16f4de837df25737947.tar.gz
gentoo-40bc49784d705340b516b16f4de837df25737947.tar.bz2
gentoo-40bc49784d705340b516b16f4de837df25737947.zip
dev-python/aiostream: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiostream')
-rw-r--r--dev-python/aiostream/Manifest1
-rw-r--r--dev-python/aiostream/aiostream-0.6.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aiostream/Manifest b/dev-python/aiostream/Manifest
index 25aa9658bef7..d3612255de2d 100644
--- a/dev-python/aiostream/Manifest
+++ b/dev-python/aiostream/Manifest
@@ -1 +1,2 @@
DIST aiostream-0.5.2.gh.tar.gz 42945 BLAKE2B 36e4f3c7834df589da3e7ec8bafb6a5b6fe40a1e868fbe0b9b81233f6721852b0e31b12144775db8785835cd5a3a0ca0a88784f7955388efd55b6ce97311b10e SHA512 282139cda0f7d08dd11af88bc3a568054906c2e0e2708f72e0ce3a67d13a44822612e3989c398ab346f8c043f17ad2e5cd2f958b1461325ad9768affec8f63fc
+DIST aiostream-0.6.1.gh.tar.gz 45466 BLAKE2B 848594d9ae191e32553dbff25ffa5926a2fd069bdc36d202f861603495ed5b33e04c4d6ae04704ca3f1d3525b73bf4f83455acc74fcfa831991c8c1ea504fe65 SHA512 0e7a87196ee7749247a6554a9347f2d8a46474db58e3793a8ac2c76b92b61e8ec7d372a05c692fcb600e81be502745ec1e7320e9dba75f50ebeff2a1ffdc35bd
diff --git a/dev-python/aiostream/aiostream-0.6.1.ebuild b/dev-python/aiostream/aiostream-0.6.1.ebuild
new file mode 100644
index 000000000000..4887cf423551
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream::' \
+ pyproject.toml || die
+ distutils-r1_src_prepare
+}