summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-09 07:49:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-09 08:30:53 +0200
commitdf9695cb5d75feda9eb47c60daf96e34b7fde7b1 (patch)
tree754f1e49a8c5e60288db38267f9bdca2317ae728 /dev-python/aiostream
parentdev-python/sqlglot: Bump to 25.24.5 (diff)
downloadgentoo-df9695cb5d75feda9eb47c60daf96e34b7fde7b1.tar.gz
gentoo-df9695cb5d75feda9eb47c60daf96e34b7fde7b1.tar.bz2
gentoo-df9695cb5d75feda9eb47c60daf96e34b7fde7b1.zip
dev-python/aiostream: Bump to 0.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiostream')
-rw-r--r--dev-python/aiostream/Manifest1
-rw-r--r--dev-python/aiostream/aiostream-0.6.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/aiostream/Manifest b/dev-python/aiostream/Manifest
index f4f66462c2ec..bfe5e6d2808a 100644
--- a/dev-python/aiostream/Manifest
+++ b/dev-python/aiostream/Manifest
@@ -1 +1,2 @@
DIST aiostream-0.6.2.gh.tar.gz 46427 BLAKE2B fa77ccc17bff587419775785200b3640038e62b7af4187abb58f321641b524e9254a3adea7020491f4fbdab8b2f36c80eb0f430e50ff15c4f311007ad5fabce2 SHA512 572ec5281122653e2b3d3927ba6206b2c4ed975fcf64cf43aae62aed154e479902cd7ef0be274d89727cd64324dcb99389cd4cb5984a8ca646e3c43836f9f2e8
+DIST aiostream-0.6.3.gh.tar.gz 46483 BLAKE2B 2bdb33aedaf791ea8451fbb21f2e90d630b92ad1eaaf961bfb804406b21dc92adde2085dfa33471f676609ffc5bb5414dfe8eb0573a7b54dfcbfaae9eca3cbee SHA512 867a4a0dac2fd0d086ee847a30c008ac480acf7b52d0ddc018a2d9f6012ee0ca804309ef8a6af97c2d7983e6699ec454a71ca1129ea1d4ca99c8d2577762b956
diff --git a/dev-python/aiostream/aiostream-0.6.3.ebuild b/dev-python/aiostream/aiostream-0.6.3.ebuild
new file mode 100644
index 000000000000..6c43c63606c6
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream::' \
+ pyproject.toml || die
+ distutils-r1_src_prepare
+}