summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-10 18:40:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-10 22:11:51 +0100
commit4d38e2666da9f45e6b228a790e6f67b018ca27d0 (patch)
tree4c035152d8f1552e27e08cee1e068d9191cace19 /dev-python/apispec
parentdev-python/cython: Bump to 3.0.8 (diff)
downloadgentoo-4d38e2666da9f45e6b228a790e6f67b018ca27d0.tar.gz
gentoo-4d38e2666da9f45e6b228a790e6f67b018ca27d0.tar.bz2
gentoo-4d38e2666da9f45e6b228a790e6f67b018ca27d0.zip
dev-python/apispec: Bump to 6.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-6.4.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 5b00292d7274..1210b1837ef3 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-6.3.1.tar.gz 77634 BLAKE2B e98a4d14f12248b27af1b5b12b642e416af7cf4f36386406ad0784e7d8930a71391de2ed627d6093e907048bb3a145abf06fca1b5b3e0595346d45fd6be6775f SHA512 977d9f890728a336b8e604f5ab7feb850f0f65e9fb64aa10cb2697d27bbd89137c6b08719b6cc422efc11c80cea6f6646709c33d340b0a63345fe93f2aa92902
+DIST apispec-6.4.0.tar.gz 79114 BLAKE2B 998b153a3d80c45247148210a929a0713d930560a4219dc0da0791e02480ff2a99a74d0b8bc2c170534f7d9e4e05a5fa231fa1d0eaf9359191e7ea6f37e5caf3 SHA512 2b9ceb99945c2e40e00af9f1626d0bd45cdb853fea1b75c58ef312b42b10d521405138c3bc788a33bf38eb31fc9220ed8e9a23c6a3c8980fc5549688d999dcdf
diff --git a/dev-python/apispec/apispec-6.4.0.ebuild b/dev-python/apispec/apispec-6.4.0.ebuild
new file mode 100644
index 000000000000..df8ddd83f780
--- /dev/null
+++ b/dev-python/apispec/apispec-6.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}